ALIX nanobsd boot issues

Mateusz Viste mateusz at
Wed Nov 20 15:46:02 UTC 2013


Alix is a 32 bit i586 Geode cpu, and your build machine seems to be an 
amd64 - I'd advise building on the same arch, it makes things a bit 
simpler :)

Anyway, I recently played a bit with nanoBSD myself (on an Alix box, 
too, and on a 9.2 system like you), and at the end I gave up with the 
specific 'pcengines' script. I used the generic script 
instead, modified the conf file a bit (for example added "customize_cmd 
cust_comconsole"), and then it worked like a charm.

I documented all my steps and configuration files here:

Also, note that Alix uses a unusual default serial speed (38400 bps), 
while the nanobsd script resets the serial port to classic 9600 bps.



On 11/20/2013 04:26 PM, Dimitar Vassilev wrote:
> Hello all,
> I've cooked myself a nice Nanobsd set for my Alix 1D. I'm having issues
> with serial console not showing any messages over the cable. Cable is OK.
> Tried swapping the com ports and still nothing
> My configs are located at
> The build host is
> FreeBSD 9.2-STABLE FreeBSD 9.2-STABLE #1 r256284: Fri
> Oct 11 02:42:10 EEST 2013
> root at
> amd64
> CPU: Intel(R) Core(TM) i5-2500 CPU @ 3.30GHz (3292.60-MHz K8-class CPU)
>    Origin = "GenuineIntel"  Id = 0x206a7  Family = 0x6  Model = 0x2a
> Stepping = 7
>    AMD Features=0x28100800<SYSCALL,NX,RDTSCP,LM>
>    AMD Features2=0x1<LAHF>
>    TSC: P-state invariant, performance statistics
> real memory  = 17179869184 (16384 MB)
> avail memory = 16423579648 (15662 MB)
> Event timer "LAPIC" quality 600
> ACPI APIC Table: <INTEL  DQ67SW  >
> FreeBSD/SMP: Multiprocessor System Detected: 4 C
> I tried also booting without disabling VGA - system boots up, but I'm
> unable to get a login prompt
> I would appreciate if someone is willing to advise me where I'm wrong?
> Am I removing too much software or something else?
> Should I try another card?
> Thanks,
> Dimitar

More information about the freebsd-questions mailing list