rare, random issue with read(), mmap() failing to read entire file

Peter Jeremy peter at rulingia.com
Mon Nov 18 19:14:33 UTC 2013

On 2013-Nov-15 18:56:09 -0800, John Refling <netbsdrat at gmail.com> wrote:
>I'm having some very insidious issues with copying and verifying (identical)
>data from several hard disks.  This might be a hardware issue or something
>very deep in the disk / filesystem code.  I have verified this with several
>disks and motherboards.  It corrupts 0.0096% of my files, different files
>each time!

My gut feeling is that this is a hardware issue.  Since you've tried
different systems, that would seem to rule them out.

Have you tried different USB enclosures/cables/etc?  I'm never comfortable
running disks over USB.

Are you able to try ZFS?  It inherently checksums data and should quickly
show up any hardware issues.

Peter Jeremy
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 326 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20131119/e3a78920/attachment.sig>

More information about the freebsd-questions mailing list