freebsd-update question

doug at doug at
Sat May 4 18:22:55 UTC 2013

I had an 8.2 system that I wanted to take to 8.4. First I tried upgrade to 8.4, 
getting (in essence) can't do that. So I upgraded 8.2 which worked giving the 
end-of-life warning. But seemed work. I then did an upgrade to 8.3 with:

    freebsd-update -r 8.3-RELEASE upgrade

The first part, downloading the diffs and inspecting the system seemed ok. The 
install seemed ok up to the point it wanted to edit files. It wanted to edit and neither of which had local changes and then it 
started wanting to delete all the files in /etc. I aborted the process when it 
got to rc.conf. The message was something like, "deleting file hosts.allow no 
longer in 8.3". Happily aborting the process left the system unchanged.

Aside from, what could I have done wrong? My question is should we be able to 
trust freebsd-update on expired systems if it says a mirror exists and then sets 
about doing its thing? Can this happen in the normal process of removing update 
'cruft' from the mirrors?

Douglas Denault
doug at
Voice: 301-217-9220
   Fax: 301-217-9277

More information about the freebsd-questions mailing list