gettext problem in FreeBSD 8.3 system hosed

Antonio Olivares olivares14031 at
Mon Mar 25 16:52:03 UTC 2013

Dear folks,

As following /usr/port/UPDATING, I ran into a bit of trouble.  System
is hosed and I cannot update any ports.  I tried to follow advice

  AFFECTS: users of converters/libiconv and devel/gettext
  AUTHOR: bapt at

  libiconv now handles the lib/charset.alias file instead of devel/gettext.
  If you are using pkgng 'and' upgrading from source with portupgrade or
  portmaster, first delete gettext, upgrade libiconv, then reinstall gettext.

  # pkg delete -f devel/gettext
  # portmaster converters/libiconv devel/gettext
  # pkg delete -f devel/gettext
  # portupgrade converters/libiconv devel/gettext

but I get error(s) in gettext.  I see that there is a small problem
with gettext:

How can I get around it, I made errors by deleting devel/gmake, and
devel/glib20 and I tried to reinstall these, I did a make deinstall
reinstall to see if I could bypass the error, but update(s) always
fail with gettext.  Any ideas/suggestions to fix this problem?

Thanks in Advance,


More information about the freebsd-questions mailing list