security/heimdal generates openssl conflict [was - Re: Installing openssl from ports]

Shane Ambler FreeBSD at ShaneWare.Biz
Sat Mar 23 08:42:41 UTC 2013

On 23/03/2013 00:21, Jim Ballantine wrote:

> Both openssl and heimdal install fine from the base system src, it's
> only when I try to install openssl from the ports, with heimdal
> installed by the base system that I get the error.
> When I run make install, what I get before the conflict message is:
> ===>  Compressing manual pages for openssl-1.0.1_8zopenssl-1.0.1_8
> ===>  Running ldconfig /sbin/ldconfig -m /usr/local/lib Installing
> openssl-1.0.1_8...pkg: openssl-1.0.1_8 conflicts with
> heimdal-1.5.2_4 (installs files into the same place). Problematic
> files: /usr/local/man/man3/DH_generate_key.3.gz
 > *** [fale-pkg] Error code 70

I'll make the subject a bit more descriptive and cc the heimdal

The error appears to be generated by pkg and would indicate that you
have installed heimdal from ports. heimdal uses libcrypto from openssl
and may have been installed as a dependency for another port.

The base system doesn't install into /usr/local and pkg shouldn't
monitor any files installed by the base system, so the conflict with
/usr/local/man/man3/DH_generate_key.3.gz must be from the heimdal port.

I just tried a compile of heimdal within tinderbox where I have set
WITH_OPENSSL_PORT=true and the log for the heimdal indicates that it
deletes man pages installed by security/openssl. So either heimdal
installs a duplicate copy of the openssl man pages or it erroneously
includes the man pages in it's package list generation.

part of tinderbox log -

====================<phase 7: make package>====================
===>  Building package for heimdal-1.5.2_4
Deleting heimdal-1.5.2_4

=== Checking filesystem state
list of files present before this port was installed but missing after
it was deinstalled)
./usr/local/man/man3/DES_cbc_cksum.3.gz missing
./usr/local/man/man3/DH_free.3.gz missing
./usr/local/man/man3/DH_generate_key.3.gz missing
./usr/local/man/man3/DH_get_default_method.3.gz missing
./usr/local/man/man3/RSA_new.3.gz missing
./usr/local/man/man3/RSA_new_method.3.gz missing
./usr/local/man/man3/RSA_set_method.3.gz missing
Deleting sqlite3-
Deleting openssl-1.0.1_8
pkg_delete: file '/usr/local/man/man3/DH_generate_key.3.gz' doesn't exist
pkg_delete: file '/usr/local/man/man3/DH_new.3.gz' doesn't exist
pkg_delete: file '/usr/local/man/man3/DH_set_method.3.gz' doesn't exist
pkg_delete: file '/usr/local/man/man3/DES_set_odd_parity.3.gz' doesn't exist
pkg_delete: file '/usr/local/man/man3/DES_string_to_key.3.gz' doesn't exist
pkg_delete: couldn't entirely delete package `openssl-1.0.1_8'
(perhaps the packing list is incorrectly specified?)
Deleting libtool-2.4.2
Deleting libXt-1.1.1,1
Deleting db41-4.1.25_4

More information about the freebsd-questions mailing list