Installing Matlab

Tijl Coosemans tijl at
Fri Mar 1 22:27:27 UTC 2013

On 01-03-2013 22:35, Vijay Kaul wrote:
> On Fri, Mar 1, 2013 at 3:27 PM, Tijl Coosemans <tijl at> wrote:
>> On 01-03-2013 21:07, Vijay Kaul wrote:
>>> On Fri, Feb 15, 2013 at 11:40 AM, Tijl Coosemans <tijl at> wrote:
>>>> On 15-02-2013 10:36, Tijl Coosemans wrote:
>>>>> On 14-02-2013 22:42, Vijay Kaul wrote:
>>>>>> I was wondering if anyone has had any recent (or not-so-recent)
>>>>>> experience installing Matlab on FreeBSD/PC-BSD? (Yes, I know about
>>>>>> octave.)
>>>>>>  I'm not entirely new to *nix, but I'm novice enough that I can't seem
>>>>>> to get this to work.
>>>>>>  Perhaps the shortest and simplest solution would be if Mathworks own
>>>>>> installer would function, but that runs as a Java Web Start
>>>>>> application, and I can't seem to get that working in Opera, Firefox,
>>>>>> or Konqueror.
>>>>>>  The automatic rout having failed, I've downloaded the files manually,
>>>>>> and I've tried to run the install script; however, it's failed as
>>>>>> well. I found this site:
>>>>>> <>,
>>>>>> which claims installation instructions for PC-BSD8.2 boiling down to:
>>>>>> open up the shell scripts and take /bin/sh --> /compat/linux/bin/sh.
>>>>>> Well, that seems to help a bit, but it also fails because the install
>>>>>> script determines my architecture to be x68, while the downloads are
>>>>>> for (what they call) a64. (My system is indeed a 64-bit system.
>>>>>> Perhaps the above instructions were for an x86 system.)
>>>>>>  I feel like if I could modify the install script sufficiently, the
>>>>>> install would work. My bash scripting is weak, though, and I worry
>>>>>> about screwing up my system and/or the installation. There are only a
>>>>>> few functions in there that are looking for architecture type, usually
>>>>>> with the output from uname. I think fixing those would work...?
>>>>>>  Could anyone help me get past this point?
>>>>>>  Thanks in advance! And please, if there's any info I can provide that
>>>>>> would be helpful, please just let me know.
>>>>>>  Output of uname -a:
>>>>>>  FreeBSD pcbsd-8517 9.1-RELEASE FreeBSD 9.1-RELEASE #2: Tue Nov 27
>>>>>> 03:45:16 UTC 2012
>>>>>> root at darkstar:/usr/obj/pcbsd-build90/fbsd-source/9.1/sys/GENERIC amd64
>>>>>>  The install script in question: <>
>>>>> Try creating this link:
>>>>> ln -s ../usr/bin/expr /compat/linux/bin/expr
>>>>> Without this link Linux scripts run the FreeBSD expr which isn't fully
>>>>> compatible.
>>>> And also, the Linux compatibility layer is 32bit so you need the x86
>>>> version of Matlab.
>>> Oh, I didn't realize that Linux on FBSD was 32 bit. Thanks for
>>> pointing that out. BTW, mathworks has stopped releasing new 32-bit
>>> versions of matlab for linux, but you can still get R2012a for 32-bit
>>> linux.
>>> Regarding the linking advice.... I have a /bin/expr and
>>> /compat/linux/usr/bin/expr. My naivety is showing, but if I did
>>> ~> ln -s /usr/bin/expr /compat/linux/usr/bin/expr
>> That's not the same command as above.
> You're right. I didn't understand at first, but I think the command
> you suggested assumed that the working directory was
> /compat/linux/bin.
>>> don't I also need to edit my path so that the script would find my
>>> link before finding the built-in FBSD command? Currently, my path
>>> begins: /sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:
>>> .... So I think the script would still use '/bin/expr'.
>> Under Linux compat the order becomes:
>> 1: /compat/linux/sbin/expr
>> 2: /sbin/expr
>> 3: /compat/linux/bin/expr       <- You need to create this as a link to 7
>> 4: /bin/expr                    <- FreeBSD expr
>> 5: /compat/linux/usr/sbin/expr
>> 6: /usr/sbin/expr
>> 7: /compat/linux/usr/bin/expr   <- Linux expr
>> 8: /usr/bin/expr
>> ...
> I don't have #s 1, 2, 5, 6, or 8. I have created 3 as a link to 7.
> (And, of course, still have 4.)
> This does, indeed, clear up any errors from expr! Thanks!!
> <snip>
> The next issue is the java errors given. A brief linux install guide I
> was given instructed:
> ... (2) install Sun/Oracle java and plugin (32-bit) and you may
> actually need to use one or two versions back from the current version
> (depending on what's in the repositories anyway)
> I have, currently, installed the "OpenJDK b27" PBI (recall I'm really
> on PC-BSD).
> Any tips or suggestions on where to find and how to install Oracle's
> Java? Why might I need an older version of Java? (Maybe they mean
> going back to JRE 6?) How would I know? (I ask about where to get
> Java, since Oracle claims only to support "linux", and the handbook
> doesn't seem to have a section on it. I'm wondering if there's a right
> and wrong way to go here.)
> The Java exceptions I see are at <>.

I suspect the installer already contains java, so you don't have to
install anything. The Linux version of java requires linprocfs though
so make sure you have the following line in /etc/fstab:

linprocfs   /compat/linux/proc	linprocfs	rw	0	0

Then mount linprocfs using: mount /compat/linux/proc

The Java exception is caused by a link error though. Can you send the
output of:

objdump -p /tmp/mathworks_22112/bin/glnx86/

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 228 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the freebsd-questions mailing list