Installing Matlab

Tijl Coosemans tijl at
Fri Mar 1 20:28:34 UTC 2013

On 01-03-2013 21:07, Vijay Kaul wrote:
> On Fri, Feb 15, 2013 at 11:40 AM, Tijl Coosemans <tijl at> wrote:
>> On 15-02-2013 10:36, Tijl Coosemans wrote:
>>> On 14-02-2013 22:42, Vijay Kaul wrote:
>>>> I was wondering if anyone has had any recent (or not-so-recent)
>>>> experience installing Matlab on FreeBSD/PC-BSD? (Yes, I know about
>>>> octave.)
>>>>  I'm not entirely new to *nix, but I'm novice enough that I can't seem
>>>> to get this to work.
>>>>  Perhaps the shortest and simplest solution would be if Mathworks own
>>>> installer would function, but that runs as a Java Web Start
>>>> application, and I can't seem to get that working in Opera, Firefox,
>>>> or Konqueror.
>>>>  The automatic rout having failed, I've downloaded the files manually,
>>>> and I've tried to run the install script; however, it's failed as
>>>> well. I found this site:
>>>> <>,
>>>> which claims installation instructions for PC-BSD8.2 boiling down to:
>>>> open up the shell scripts and take /bin/sh --> /compat/linux/bin/sh.
>>>> Well, that seems to help a bit, but it also fails because the install
>>>> script determines my architecture to be x68, while the downloads are
>>>> for (what they call) a64. (My system is indeed a 64-bit system.
>>>> Perhaps the above instructions were for an x86 system.)
>>>>  I feel like if I could modify the install script sufficiently, the
>>>> install would work. My bash scripting is weak, though, and I worry
>>>> about screwing up my system and/or the installation. There are only a
>>>> few functions in there that are looking for architecture type, usually
>>>> with the output from uname. I think fixing those would work...?
>>>>  Could anyone help me get past this point?
>>>>  Thanks in advance! And please, if there's any info I can provide that
>>>> would be helpful, please just let me know.
>>>>  Output of uname -a:
>>>>  FreeBSD pcbsd-8517 9.1-RELEASE FreeBSD 9.1-RELEASE #2: Tue Nov 27
>>>> 03:45:16 UTC 2012
>>>> root at darkstar:/usr/obj/pcbsd-build90/fbsd-source/9.1/sys/GENERIC amd64
>>>>  The install script in question: <>
>>> Try creating this link:
>>> ln -s ../usr/bin/expr /compat/linux/bin/expr
>>> Without this link Linux scripts run the FreeBSD expr which isn't fully
>>> compatible.
>> And also, the Linux compatibility layer is 32bit so you need the x86
>> version of Matlab.
> Oh, I didn't realize that Linux on FBSD was 32 bit. Thanks for
> pointing that out. BTW, mathworks has stopped releasing new 32-bit
> versions of matlab for linux, but you can still get R2012a for 32-bit
> linux.
> Regarding the linking advice.... I have a /bin/expr and
> /compat/linux/usr/bin/expr. My naivety is showing, but if I did
> ~> ln -s /usr/bin/expr /compat/linux/usr/bin/expr

That's not the same command as above.

> don't I also need to edit my path so that the script would find my
> link before finding the built-in FBSD command? Currently, my path
> begins: /sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:
> .... So I think the script would still use '/bin/expr'.

Under Linux compat the order becomes:

1: /compat/linux/sbin/expr
2: /sbin/expr
3: /compat/linux/bin/expr       <- You need to create this as a link to 7
4: /bin/expr                    <- FreeBSD expr
5: /compat/linux/usr/sbin/expr
6: /usr/sbin/expr
7: /compat/linux/usr/bin/expr   <- Linux expr
8: /usr/bin/expr

> The install of the 32-bit linux matlab does still throw the error:
> expr: illegal option -- r
> expr: usage: expr [-e] expression
> presumably because I need to use the linux version. (The install
> script itself is essentially identical to the last.) It also is
> throwing some Java exceptions, but maybe let's take this one error at
> a time!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 228 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the freebsd-questions mailing list