USB can't mount msdosfs drive

Bernt Hansson bah at
Wed Jun 5 23:22:10 UTC 2013

On 2013-06-05 22:12, Joseph Mays wrote:
>> did you already try to access da2 instead of da2s1?
> Yeah, tried that early on, got the same result.
> root at warehouse:/backups/postgres-02/info # mount_msdosfs /dev/da2 /usb2
> mount_msdosfs: /dev/da2: Invalid argument
>> But just to be fully sure: This is a USB stick / thumb drive, right?
> Yes. It's one of several thumb drives that were mounted in the back of
> some linux machines at remote sites we help a customer with. The client
> is unsure what was on them, but needs to know. We asked them to gather
> them up and stick them into usb ports on a freebsd machine we have
> access to and manage at their location (in another state). Most of them
> I got mounted as either msdosfs, or ufs, or ntfs, or extfs2, and was
> able to get the data off them. This thumb drive is one of two holdouts.

If you do a ls /dev/da* What does it show.

More information about the freebsd-questions mailing list