Delete a directory, crash the system

Polytropon freebsd at
Sun Jul 28 05:46:12 UTC 2013

On Sat, 27 Jul 2013 13:57:31 -0500, David Noel wrote:
> > So the system panics in ufs_rmdir(). Maybe the filesystem is
> > corrupt? Have you tried to fsck(8) it manually?
> fsck worked, though I had to boot from a USB image because I couldn't
> get into single user.. for some odd reason.

>From your initial description, a _severe_ file system defect
seems to be a reasonable assumption. Make sure fsck is run
in foreground prior to bringing up the system. The option
background_fsck="NO" in /etc/rc.conf will make sure you
won't encounter this problem again (_if_ it was related
to the file system). Always make sure you're booting into
a fsck'ed environment.

You could also use a S.M.A.R.T. analysis tool such as smartmon
(from ports) to make sure the OS didn't panic because of a
hard disk defect. I'm just mentioning this because I have
sufficient exoerience in this field. :-)

> > Even if the filesystem is corrupt, ufs_rmdir() shouldn't
> > panic(), IMHO, but fail gracefully. Hmmm...
> Yeah, I was pretty surprised. I think I tried it like 3 times to be
> sure... and yeah, each time... kaboom!

It's really surprising that a (comparable) high-level function
could fail in that drastic way, but on the other hand, one would
assume that there is a _reason_ for this behaviour.

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list