FreeBSD 9.1 won't boot after install

Warren Block wblock at
Fri Jul 5 22:25:44 UTC 2013

On Fri, 5 Jul 2013, James E. Pace wrote:

> I bought an HP Pavilion p7-1597c [1] system last week.  It is Intel Core
> i5-3330, with a Seagate 1.5 TB SATA drive and 12 GB of memory, shipped with
> Windows 8.
> I have disabled Secure Boot and enabled Legacy device booting.

That says the disk is GPT partitioned for UEFI.

> I am able to complete the install of FreeBSD 9.1/amd64 from the CD without
> any problems.  However, when I attempt to boot, it doesn't.
> Originally I was trying to dual boot with Win 8, but eventually I rendered
> Win8 unbootable.  So, now I have given FreeBSD the whole disk.  I have done
> the standard install.  I found instructions to have the install use MBR
> (instead of GPT), but that also doesn't work.

In what way?

> After an install, I get to the boot0 (the F1 boot menu thing) screen, but
> when it tries to boot, it prints "#" and doesn't boot.  When trying to
> share the disk with Windows, mostly I'd get boot errors about not having a
> bootable device (ERROR: No boot disk has been detected or the disk has
> failed.).

boot0 is the multi-boot loader.  I'm reasonably sure it will not work on 
a GPT disk.  GPT needs the PMBR loader.  This should be correctable by 
using the Shell option of the install disk:
   # gpart bootcode -b /boot/pmbr -p /boot/gptboot -i 1 ada0

The installer would write that by default on a blank disk.  I don't know 
what it does when partitions are added to a GPT disk.  For that matter, 
I'm not sure how you got boot0 on there.

> In the BIOS setting, I've tried both IDE and AHCI in "Storage Options ->
> SATA emulation".

AHCI is preferred and will go a little bit faster, but either will work.

> PC-BSD 9.1 has the same results.  It installs fine, but resets after
> selecting something at the boot0 prompt.

boot0 strikes again.  AFAIK, the only option for multi-boot on GPT disks 
is EasyBCD or grub (untested).  But really, a VM is far preferable to 
multi-boot for many situations.

> FreeBSD 8.4 wouldn't install because the installer didn't have device node
> for /dev/ad4s1b in /dev in order to create the filesystems.

That sounds familiar, but I can't find notes on solving it.  I would 
recommend 9.x anyway.

If there is nothing on the disk to lose, I would start from scratch by 
going to the shell from the installer:
   # gpart destroy -F ada0

Return to the installer, and it should find the entire disk 

If you really want to multi-boot, reinstall Windows 8.  Leave part of 
the disk unpartitioned for FreeBSD.  Install EasyBCD in Windows 
( and install FreeBSD in a new GPT 
partition, and maybe it will be easy.  I have not tried a multi-boot 
install with Windows 8 or GPT/EFI, so can't really say what it will 
take.  If you do that, take notes and post them somewhere.

More information about the freebsd-questions mailing list