What compiler is used to build a port

Olivier Nicole Olivier.Nicole at cs.ait.ac.th
Mon Jul 1 08:36:54 UTC 2013


Hi,

I have a strange situation: 2 machines, 9.1 p4, on the first machine,
graphicslibfpx build with the stock compiler:

$ make
===> Fetching all distfiles required by libfpx-1.3.1.1 for building
===>  Extracting for libfpx-1.3.1.1
=> SHA256 Checksum OK for libfpx-1.3.1-1.tar.xz.
===>  Patching for libfpx-1.3.1.1
===>  Applying FreeBSD patches for libfpx-1.3.1.1
/usr/bin/sed -i '' -e '/^#include "fpxlib-config.h"/d'   /usr/ports/graphics/libfpx/work/libfpx-1.3.1-1/basics/filename.cpp      /usr/ports/graphics/libfpx/work/libfpx-1.3.1-1/oless/h/owchar.h         /usr/ports/graphics/libfpx/work/libfpx-1.3.1-1/ole/gen_guid.cpp         /usr/ports/graphics/libfpx/work/libfpx-1.3.1-1/fpxlib.h
===>  Configuring for libfpx-1.3.1.1
===>  Building for libfpx-1.3.1.1
Warning: Object directory not changed from original /usr/ports/graphics/libfpx/work/libfpx-1.3.1-1
g++  -O2 -pipe -DHAVE_WCHAR_H -DHAVE_DLFCN_H -DHAVE_SYS_TIME_H...

and on the other machine it insists on using gcc >4.4 (which is
actually a mistake, libfpx will *not* compile with gcc 4.4 or gcc
4.6):

$ make 
===> Fetching all distfiles required by libfpx-1.3.1.1 for building
===>  Extracting for libfpx-1.3.1.1
=> SHA256 Checksum OK for libfpx-1.3.1-1.tar.xz.
===>  Patching for libfpx-1.3.1.1
===>  Applying FreeBSD patches for libfpx-1.3.1.1
/usr/bin/sed -i '' -e '/^#include "fpxlib-config.h"/d'   /usr/ports/graphics/libfpx/work/libfpx-1.3.1-1/basics/filename.cpp      /usr/ports/graphics/libfpx/work/libfpx-1.3.1-1/oless/h/owchar.h         /usr/ports/graphics/libfpx/work/libfpx-1.3.1-1/ole/gen_guid.cpp         /usr/ports/graphics/libfpx/work/libfpx-1.3.1-1/fpxlib.h
===>   libfpx-1.3.1.1 depends on executable: gcc46 - not found
===>    Verifying install for gcc46 in /usr/ports/lang/gcc
Making GCC 4.6.3 for x86_64-portbld-freebsd9.1 [c,c++,objc,fortran,java]
===>  Found saved configuration for gcc-4.6.3
===> Fetching all distfiles required by gcc-4.6.3 for building
===>  Extracting for gcc-4.6.3
=> SHA256 Checksum OK for gcc-4.6.3.tar.bz2.
===>   gcc-4.6.3 depends on file: /usr/local/bin/perl5.14.4 - found

What could cause aport to request for a different compiler version
when both machines are very similar?

Best regards,

Olivier


More information about the freebsd-questions mailing list