ZFS root, error 2 when mounting root

Paul Kraus paul at kraus-haus.org
Mon Feb 25 15:21:01 UTC 2013

On Feb 25, 2013, at 10:14 AM, bw <bw.mail.lists at gmail.com> wrote:

> On 02/25/2013 03:13 PM, Paul Kraus wrote:
>> On Feb 24, 2013, at 4:42 AM, bw.mail.lists <bw.mail.lists at gmail.com> wrote:
>>> Basically, I tried to follow https://wiki.freebsd.org/RootOnZFS/GPTZFSBoot/9.0-RELEASE, but ended up with a system that didn't know how to mount /.
>>> There are two scripts attached.
>> I did not see any attachments.
> Mail list got rid of them, I didn't know it will do that. Appended inline at the end of this mail. Stuff will probably get wrapped, but at least it's there.

> That was my understanding, too, but the instructions on the wiki say there's no need to copy the cache file. In fact, there is no cache file to copy, since the pool is created with
> zpool create -o altroot=/mnt -O canmount=off zroot mirror /dev/gpt/g0zfs /dev/gpt/g1zfs
> No cache file. The wiki article was changed recently to eliminate that part, the message on the wiki is: "Fix so that the default instructions does not install data directly to the zroot pool. Simplify instructions regarding cache files, they are no longer needed. Fixes and cleanups."
> Either the instructions are wrong, or something in my script is. I assume it's my script.

	The instructions noted above are now INCORRECT for 9.0 (I have not tried this with 9.1 yet) as you MUST manually put the zpool.cache file in place for it to work correctly (I tried a couple different variations when I first setup my systems a few months ago and learned this the hard way :-) I have *lost* of experience with ZFS under Solaris 10 but am relatively new (about a year) to FreeBSD.

Paul Kraus
Deputy Technical Director, LoneStarCon 3
Sound Coordinator, Schenectady Light Opera Company

More information about the freebsd-questions mailing list