Can anyone direct me to some information about what WITHOUT_PROFILE="YES" actually means.

dweimer dweimer at
Mon Feb 4 22:46:38 UTC 2013

On 02/04/2013 3:25 pm, Michael Powell wrote:
> dweimer wrote:
>> I have ran into a recent issue, after a lot of trouble shooting I 
>> have
>> narrowed it down to something in my /etc/src.conf
>> the full file just has:
>> Of course bind and ntp are added in by ports after the system is 
>> built,
>> everything compiles, I have a very specific issue with one thing not
>> working on an installed port, with no apparent error.  To make a long
>> story short though one of my build attempts, I forgot to copy the
>> /etc/src.conf file to the new system.  And well the problem was gone,
>> when I discovered that's what I did differently, I commented out all
>> lines on a different system rebuilt and installed, sure enough it
>> worked.  Looking at the src.conf options that I was using, I can't 
>> see
>> how any option other than the WITHOUT_PROFILE could possibly be 
>> causing
>> the problem.  Though I am in the process of building systems with
>> different options removed in an attempt to find out for sure.
>> The WITHOUT_PROFILE was added from a help document I read some time 
>> ago
>> about upgrading from source, and hasn't caused any problems before 
>> now.
>> I know it instructs the build process to avoid compiling profiled
>> libraries.  But my searching hasn't been able to lead me to what the
>> difference is between a profiled and non-profiled library is.
> I'm not a code hacker, so take with pinch of salt. In the man page for
> src.conf it declares that variable values would be ignored, and of 
> course I
> missed that. While I have WITHOUT_PROFILE= true in my src.conf, the 
> correct
> use is simply WITHOUT_PROFILE by itself. Since I have never 
> experienced any
> form of difficulty perhaps the difference here is the quotation marks. 
> Maybe
> something is malfunctioning from the "".  See if removing these helps?
> Also, from what I understand what's in src.conf should only apply to
> building the system, e.g code located under /usr/src. I've always 
> taken this
> to mean it should not apply to building anything in ports.
> My limited understanding is that when you build profiled code you are
> inserting a little extra debug code which is utilized to measure the 
> time
> spent within internal structures, such as functions and other 
> sub-routines.
> Not that I even know how such info would get extracted at runtime,
> programmers use this to look for areas within their code that hog 
> resources
> time-wise and zero in on those to concentrate on makeing more
> efficient/faster.
> -Mike

if I remember right, from information about src.conf, I believe that


are all functionally equivalent as it does ignore the rest, though I 
could be wrong and this could be my problem.  I do know for sure that 
the WIHTOUT_BIND, WITHOUT_NTP, are working correctly as they are gone 
form the system, prior to me installing the versions from ports after 
the build/install world.

Yes this does apply only to system. With the above options buildworld / 
buildkernel / install kernel / install world/ mergemaster / reinstall 
all ports, I have my problem.  Remove all options, repeat no problem.  
Remove just WITHOUT_PROFILE repeat again, problem is back.  So I was 
wrong as to that line being the cause, at least by itself.

I did a lot of initial testing with port option changes, and changes to 
make.conf on my system, thought maybe it was clang, etc.  Didn't get 
anywhere, the system is running on a ZFS boot partition, and as a last 
effort I tried on UFS.  It worked, but I also realized I forgot the 
src.conf settings.  I copied my ZFS systems boot environment and rebuilt 
without src.conf, it now works as well.

Currently doing a fresh install on ZFS to build from ground up with the 
same process used originally, except without the src.conf and confirm I 
can repeat its success.  Then I can do some more testing with adding 
options back into the src.conf to try and narrow down which of those 
options is causing the problem.  If I can figure out which one, or 
combination of them is the cause, then I will hopefully have something 
that can lead to someone with more knowledge than I have being able to 
discover why its having the problem.

The port doesn't fail to compile it installs fine, and 99.5% of it runs 
perfect, just one little thing that I need to work hangs up for about 5 
minutes, before timing out, but doesn't log an error, even with insanely 
verbose debugging, it acts as if it completed but it didn't.

I posted another message about the specific problem several days ago, 
before I had it figured out to be caused somehow by something in the 
src.conf file.  I am trying to run Squid (version 3.2.6 is the current 
port) in reverse proxy, the problem is only when doing a post via HTTPS 
above a certain size, somewhere between 2k and 3.2k is where it begins.

    Dean E. Weimer

More information about the freebsd-questions mailing list