vfs.root.mountfrom with geli

Fabian Keil freebsd-listen at fabiankeil.de
Mon Feb 4 12:13:38 UTC 2013

mhca12 <mhca12 at gmail.com> wrote:

> I followed the guide on dan.me.uk to install FreeBSD 9.1 amd64
> but I get always stuck because the kernel doesn't ask me for the
> passphrase and doesn't find the /dev/gpt/enc.eli where enc is the
> label I gave to the root partition. I also tried with /dev/ada0p3.eli
> without success.
> Tried the following two /boot/loader.config variations:
> 1:
> geom_eli_load="YES"
> vfs.root.mountfrom=”ufs:/dev/gpt/enc.eli”
> 2:
> geom_eli_load="YES"
> vfs.root.mountfrom=”ufs:/dev/ada0p3.eli”
> I can geli attach /dev/gpt/enc or /dev/ada0p3 successfully from
> the livecd.
> Can you advise me what I might have done wrong or what I
> should try?
> https://www.dan.me.uk/blog/2012/05/05/full-disk-encryption-in-freebsd-9-x-well-almost/

This guide doesn't seem to match your configuration.
It uses ada0p3.eli for swapping and additionally uses keyfiles.

Without knowing your actual configuration it's impossible to
give proper advice. You could check with "geli list ada0p3" if
the boot flag is set, but that's obviously just a wild guess ...

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20130204/19df140c/attachment.sig>

More information about the freebsd-questions mailing list