Crucial SSD firmware upgrade -- usb flash drive issues

Gary Aitken freebsd at
Fri Feb 1 21:17:21 UTC 2013

On 02/01/13 11:03, Sean Cavanaugh wrote:
>> -----Original Message-----
>> From: owner-freebsd-questions at [mailto:owner-freebsd-
>> questions at] On Behalf Of Gary Aitken
>> Sent: Friday, February 01, 2013 12:55 PM
>> To: FreeBSD Mailing List
>> Subject: Crucial SSD firmware upgrade -- usb flash drive issues
>> I've got a Crucial m4 SSD which needs a firmware upgrade.
>> From the Crucial website I've downloaded an image which supposedly is an
>> iso image bootable from either CD or a usb stick.
>> Since the fbsd install images are different for booting from cd and usb
> flash
>> drives (the flash image is significantly larger), I'm wondering if there's
>> anything I need to be aware of when attempting this.
>> I tried copying the ssd firmware update image to a flash drive using:
>>   dd if=firmwareupdate.iso of=/dev/da0 bs=64k which seemed to work.
>> However, when I attempt to boot the device, BIOS complains about it not
>> being bootable and says to fix it or select something else which is
> bootable.
>> I know the drive can be bootable because I used it for the fbsd 9.1 usb
> boot
>> image and it worked fine.
>> The documentation for the SSD firmware upgrade says "Create a Bootable
>> USB Drive"
>> with the following steps (summarized here, no real content omitted):
>>   1.  Start with a newly formatted USB drive
>>   2.  Open a USB installer program.  If you don't have one, you may
> download
>>       a free one such as Universal USB Installer...
>>   3.  If you are using the Universal USB Installer, then:
>>   3a. At the Step 1 drop down box, scroll to the bottom and select
>>       the last option: Try Unlisted Linux ISO
>>   3b. Go to step 2 (in the pgm) and browse to the firmware ISO that you
>>       downloaded earlier
>>   3c. Go to step 3 (in the pgm) and select the flash drive on which you
>>       want to install the ISO
>>   3d. Click the Create button and click Format E:\Drive
>>   3e. A sequence of screens will appear and disappear...
>> The above is all highly confusing to me, as it's not clear who's doing
> what.
>> I'm guessing the "Universal Installer Program" actually writes a boot
> block
>> and then the bootable image someplace beyond that, and the iso image
>> supplied is not really a complete bootable image for a flash drive -- it's
>> missing the boot blocks.
>> Can anyone suggest a way to create a bootable flash drive using this
> image?
>> _______________________________________________
>> freebsd-questions at mailing list
>> To unsubscribe, send any mail to "freebsd-questions-
>> unsubscribe at"
> Please see the below site for a script to convert the .ISO into a .IMG that
> can be dd written to the thumb drive

Thanks, that was a help.

However, when it boots, I get the following:

  No /boot/loader
  FreeBSD/x86 boot
  Default: 0:ad(0,a)/boot/kernel/kernel

I can mount the thumb drive as a ufs file system, which looks like this:

Assuming this is all good as a stand-alone linux image, what do I need to 
enter at the boot: prompt to get it to boot?  It's not clear to me what the
code to be booted is.

The isolinux.cfg file looks like this:

  DEFAULT default

  DISPLAY bootMsg.txt

  LABEL default
        KERNEL memdisk
        append initrd=boot2880.img floppy raw

  LABEL alternate
        KERNEL memdisk
        append initrd=boot2880.img floppy

Thanks for any hints...


More information about the freebsd-questions mailing list