musicpd doesn't play musics

David Demelier demelier.david at
Sat Dec 28 12:40:29 UTC 2013

On 28/12/2013 11:54, Zsolt Udvari wrote:
> Now I have six dsps:
> /dev/dsp0.0 /dev/dsp0.1 /dev/dsp0.2 /dev/dsp0.3 /dev/dsp0.4 /dev/dsp0.5
> 2013/12/28 Zsolt Udvari <udvzsolt at>:
>> Thanks for your answer!
>> 2013/12/28 David Demelier <demelier.david at>:
>>> Try to remove the device from audio_output. I personally have :
>> First I've tried with the default musicpd.conf, without oss/device.
>> Now I've tried again but it doesn't work :(
>> Vlc has audio output, and I can hear youtube videos, etc. And "cat
>> anyfile > /dev/dsp" produces some "melody".
>> I think the problem is in musicpd (because other programs has voice).
>> But I noticed a strange thing: I've /dev/dsp0.0, sometimes I've got
>> /dev/dsp0.1 too, and now only /dev/dsp0.1 (without /dev/dsp0.0). Is it
>> normal?
>>> audio_output {
>>>         type            "oss"
>>>         name            "My OSS Device"
>>>         mixer_device    "/dev/mixer"
>>>         mixer_control   "vol"
>>> }
>>> And it works. Do you have any output at all? mplayer, vlc, or so?
>>> Regards

Show your musicpd options (musicpd -V) and take a look at your logs. I
remember once that my files were in a format not compiled in but it was
shown in the mpc list.

David Demelier

More information about the freebsd-questions mailing list