How to compile a port with GCC instead of clang

Lena at Lena at
Sun Dec 8 23:05:34 UTC 2013

> From: Peter Harrison <four.harrisons at>

> Sunday,  8 December 2013 at 12:47:06 +0100, Roland Smith said:
> > On Sun, Dec 08, 2013 at 10:54:55AM +0000, Peter Harrison wrote:
> >> 
> >> How can I compile www/chromium with GCC instead of clang?
> >> If I compile it with clang I end up with a broken binary that won't render
> >> pages properly. If I compile it with gcc it works flawlessly.
> >> But the knob to choose gcc has been removed in the recent updates.
> >> So now I have a broken chromium. How can I compile it with gcc instead?
> > 
> > Add the following to your /etc/make.conf:
> > 
> > .if ${.CURDIR:M*/www/chromium}
> > USE_GCC?=yes
> > .endif
> > 
> > See /usr/ports/Mk/ for the possible values of USE_GCC.
> Thanks Roland.
> That worked, but sadly seems to have just uncovered why the gcc option
> was removed. Built with clang my chromium still doesn't function properly.
> Attempting to build with gcc produces the error below.
> Anyone got any idea either how to build a functioning chromium with clang,
> or how to successfully build it with gcc?
> Attempting to build with gcc I get:
> [2/12492] CC obj/third_party/lzma_sdk/lzma_sdk.7zAlloc.o
> FAILED: gcc46

I use FreeBSD 8.4-RELEASE-p4 i386.
According to /usr/ports/UPDATING 20131008, I use
in /etc/make.conf - then chromium is attempted to be built using GCC 4.7,
but chromium build fails, though later - on some step 5xxx/12xxx.

Which last version of Chromium did you build and use successfully?

Fresh Chromium 31.0.1650.63 built with clang doesn't work for me
(doesn't render and
installed with pkg_add (I don't use pkgng) seems to work somewhat better.
I use Firefox, I'm trying to only test a broken website (
in Chromium.

More information about the freebsd-questions mailing list