slapd failing to start after update

Carmel carmel_ny at
Sat Aug 24 11:31:20 UTC 2013

On Sat, 24 Aug 2013 06:05:02 -0400
Carmel articulated:

> I ran portupgrade last night to upgrade my ports. It upgraded both
> openldap24-server and openldap24-client. Now, the server refuses to
> start. Upon reboot, I get this message: "slapd failed to start". I
> went to the rc.d directory and tried to start it manually, but that
> failed also.
> I do not know where the log file, if one even exists, is so I might be
> able to find out what the problem is. I tried to manually deinstall
> and reinstall both ports and it went off without a hitch so I assume
> that they are properly installed.

Never mind, I found the problem. For the second time in the past
several months, the database had become corrupt when I updated it via
portupgrade. I discovered it when I ran this command:

	/usr/local/libexec/slapd -Tt

I guess it was a good thing that I had a recent backup.

Carmel ✌
carmel_ny at

Disclaimer: off-list followups get on-list replies or get ignored.
Please do not ignore the "Reply-To" header.

More information about the freebsd-questions mailing list