FreeBSD on ThinkPad W530

Adrian Chadd adrian at
Wed Aug 14 00:30:18 UTC 2013


Yay another FreeBSD laptop user!

Please do this:

* join the freebsd-mobile list;
* create PRs for each of your problems with -10 above!;
* the power utilisation thing is going to be fun to track down - what kind
of CPU is in there? Is it a recent Intel? I'm playing around with their
tools at the moment; maybe we can look at the power the CPU is consuming
and then add on the power from each of the other parts in your laptop until
we figure out what's drawing said power
* the brightness thing is known; a bunch of us have this issue and the
"fix" is known. Trouble is, there's no (yet) clean fix that's made it into
acpi_ibm. I'm glad there's another person who cares; it means we have more
chance of getting a real fix that works for multiple people into the tree.

As for suspend/resume - I'm glad it at least works for you. Right now I
don't even get video output upon resume. But, it's a starting point. Let's
get the PRs filed, the brightness thing pushed into -HEAD, and then start
down the path of figuring out where the power consumption is coming from.


On 13 August 2013 15:21, vermaden <vermaden at> wrote:

> Hi,
> I have just tried FreeBSD on ThinkPad W530 and I must say that its very
> disapointing experience ...
> The FreeBSD 9.2-RC1 and PC-BSD 9.2-BETA2 does not even boot from the USB
> drive - instant kernel panic and reboot.
> The FreeBSD 10.0-CURRENT was able to boot successfully and I could install
> FreeBSD onto the drive with 'ZFS Madnss' style.
> After installation with extended battery charged to 100% I have about 3
> hours of work ... while having about 10 hours on Windows (haven't tried
> Linux yet). I disabled discrete graphics (Nvidia) in the BIOS and also
> added set hw.pci.do_power_nodriver to 3, but that also did not solved the
> 'battery' problem. The powerd daemon was of course running and worked ok.
> After compiling new x11/xorg (with WITH_NEW_XORG in /etc/make.conf) along
> with x11-wm/openbox I was able to get X11 working, but I can not go back to
> console as its not implemented yet.
> The screen is 100% bright all the time because acpi_ibm module probably
> does not support this model yet (changing the dev.acpi_ibm.0.lcd_brightness
> is pointless, no effects).
> Suspend and resume works very poor, after resume the resolution is 640x640
> with all colors broken, requires restarting X11 in 'blind mode' (not
> implemented console switching).
> Of course as all of the above is not possible, using the Nvidia Optimus
> technology (graphics card switching) is probably also not possible, which
> is possible with Bumblebee on Linux, any plans on merging that
> functionality into FreeBSD?
> At least WiFi and LAN worked out of the box ...
> Now ... how can I help, what information can I provide to help resolve
> these issues:
> 1. disable power for discrete graphics card
> 2. have working screen brightness changing and working other Fn + X
> shotrcuts
> 3. I guess I will have to 'just wait' for the console switching
> implementation?
> ... or maybe I am doing it 'wrong' someone have W530 there and uses
> FreeBSD with any more degree of success then I?
> Regards,
> vermaden
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "
> freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list