Why is "pkg_glob" no longer working for me?

Tom Russo russo at bogodyn.org
Fri Apr 26 21:06:24 UTC 2013

I used to be able to run "pkg_glob" to see what packages have been updated
since a given date.  For example, if I do a big 'portupgrade -fr somepackage'
and wait overnight, then in the morning find a handful had failed, I often
find it helpful to do something like:

   pkg_glob -r somepackage -x '>= 2013-04-24'

to see what packages depend on somepackage but weren't updated when I did
the portupgrade on the 24th.

But now, I find that pkg_glob always returns absolutely nothing if I specify
a date.  I did a portupgrade -a on Thursday the 25th of April, and when I try 
to see which ports actually got updated with "pkg_glob '>=2013-04-24'", it
prints nothing. 

This has been happening for a few weeks, at least, and I wonder
an update to the portupgrade package busted it.

I have tried rebuilding the package db and ports db using pkgdb and portsdb,
with no change in behavior.

I tried looking at /var/db/pkg to see if the modification times of directories
there might help me answer my question, but far more directories have been
touched than packages actually updated (there were, as I recall, 20 pending
package upgrades when I started the process).

Anyone else have this issue?  Or am I the only one left still using portupgrade
and its associated tools?

Tom Russo    KM5VY   SAR502   DM64ux          http://www.swcp.com/~russo/
Tijeras, NM  QRPL#1592 K2#398  SOC#236        http://kevan.org/brain.cgi?DDTNM
 echo "prpv_a'rfg_cnf_har_cvcr" | sed -e 's/_/ /g' | tr [a-m][n-z] [n-z][a-m]


More information about the freebsd-questions mailing list