SOLVED: Re: Error after upgrading to php 5.4.6

Bas Smeelen b.smeelen at
Tue Sep 4 14:10:18 UTC 2012

On 09/04/2012 09:02 AM, Michael Powell wrote:
> Bas Smeelen wrote:
> [snip]
>> My previous response was sent too early :(
>> I still get errors in apache
>> [Tue Sep 04 08:14:42 2012] [error] [client] PHP Warning:
>> Unknown: Unable to allocate memory for pool. in Unknown on line 0,
>> referer:
>> [Tue Sep 04 08:14:43 2012] [notice] child pid 56172 exit signal
>> [Segmentation
>> fault (11)
>> [snip]
>> Well it turns out to be, this comes with core php I guess?
>> [snip]
I have found that the faults are present because www/pecl-APC was not 
So I reinstalled www/pecl-APC with portmaster -f and this also reinstalled 
the following ports:
     Re-install pecl-APC-3.1.12
     Re-install autoconf-2.69
     Re-install autoconf-wrapper-20101119
     Re-install gmake-3.82_1
     Re-install gettext-
     Re-install libiconv-1.14
     Re-install libtool-2.4.2
     Re-install m4-1.4.16_1,1
     Re-install perl-5.12.4_4
     Re-install help2man-1.40.11
     Re-install p5-Locale-gettext-1.05_3
     Re-install php5-5.4.6
     Re-install pcre-8.31
     Re-install pkgconf-0.8.7_2
     Re-install libxml2-2.7.8_3
     Re-install apache-2.2.22_6
     Re-install apr-ipv6-devrandom-gdbm-db42-
     Re-install db42-4.2.52_5
     Re-install gdbm-1.9.1
     Re-install automake-1.12.3
     Re-install automake-wrapper-20101119
     Re-install python27-2.7.3_3
     Re-install expat-2.0.1_2

There is nothing about this in UPDATING, should there?
This solved the problem anyway.



More information about the freebsd-questions mailing list