Gimp - problem opening images using URI's

Mike Clarke jmc-freebsd2 at
Mon Oct 22 19:59:26 UTC 2012

Gimp has recently become unable to open images using URI's, e.g.-

curlew:/home/mike% gimp -c ""
Failed to connect to socket /tmp/fam-mike/fam-

(gimp:27650): GLib-GIO-WARNING **: FAMOpen failed, FAMErrno=3

GIMP-Error: Opening '' failed: 
Could not open '' for 
reading: No such file or directory

The above is with gimp-app-2.6.12_1,1 compiled from ports with default options 
running under FreeBSD 9.0-RELEASE, all ports are up to date and there are no 
missing dependencies.

I had similar problems in the past and managed to "fix" it by 
adding "--without-gvfs" to the options in the Makefile but the problem 
reappeared after a recent upgrade to my ports. The port upgrade didn't touch 
gimp-app so I assume the problem is caused by some dependency which has been 

I've tried rebuilding gimp-app both with and without my Makefile hack and with 
and without GVFS in the config options but with no success.

The error message above is after rebuilding  from a freshly downloaded copy of 
the port to ensure none of my old edits remained and with the default options 
in make config.

It might be significant that the directory /tmp/fam-mike does not exist. I 
tried creating it but gimp produced an error "Socket directory /tmp/fam-mike 
has wrong permissions" and promptly deleted the directory. 
Recreating /tmp/fam-mike with permissions 700 got rid of the "wrong 
permissions" message but still failed to cure the problem.

Google searches haven't come up with anything directly relevant to my problem 
but do imply that the problem could be related to devel/gamin.

Could anyone offer any suggestions on how to go about resolving this?

Mike Clarke

More information about the freebsd-questions mailing list