pppoe configuration and dns name resolution

Polytropon freebsd at edvax.de
Wed Oct 17 05:34:30 UTC 2012


On Tue, 16 Oct 2012 20:38:47 +0530, Jack wrote:
> I'm new as a FreeBSD user, and trying to configure my
> pppoe connection.

I've been using PPPoE with a DSL modem for many years, using
FreeBSD 4, 5 and 7 with the system's PPPoE tools. The IP
was provided to the computer directly, so no DHCP in the
modem involved ("real modem mode").

In /etc/ppp/ppp.conf, I did simply define:

	myispname:
		set device PPPoE:xl0
		set authname customer1234567 at myispname
		set authkey XXXXXXXXX
		set dial
		set login
		add default HISADDR

No further changes to that file. Note that here, xl0 is the
interface directly connected to the modem.

And in /etc/rc.conf:

	ifconfig_xl0="192.168.0.1 netmask 0xffffff00"
	ppp_enable="YES"
	ppp_profile="myispname"
	ppp_mode="ddial"
	ppp_nat="YES"

So the system would automatically start the connection
at boot time. The tun0 interface would then be associated
the public IP designated when the PPPoE connection was up
and running.

Note that ppp_nat only has been needed to "transition" the
connection through a 2nd NIC into the local net, making my
machine a gateway (including related services, such as natd
and dhcpd).

I also think initializing the NIC xl0 is not entirely needed,
maybe "up" would have been sufficient.

For actually being able to use PPPoE, I did add the required
components to the kernel, because that approach was "state of
the art" at those times. :-)

In /etc/resolv.conf I did add the nameservers published by
my ISP. Anything worked automatically, I did not need to make
further changes.

Basically my setup looks like yours, except that (as I said) I
did not use any "additional features" of the DSL modem (as it
did not have such features). :-)


-- 
Polytropon
Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...


More information about the freebsd-questions mailing list