Port update hosed entire system

Arthur Chance freebsd at qeng-ho.org
Mon Oct 1 11:20:42 UTC 2012

On 10/02/12 11:20, Rod Person wrote:
> On Mon, 1 Oct 2012 08:02:54 +0200
> Polytropon <freebsd at edvax.de> wrote:
>> On Mon, 1 Oct 2012 20:08:29 -0400, Rod Person wrote:
>>> Hi All,
>>> I was attempting to update ports that used libogg with the command
>>> portmaster -d -y -r libogg
>>> I went away and came back some hours later and some updates had
>>> failed. Now my shell segfaults on any command such as ls, clear or
>>> su I tried to login on another console as root and after giving the
>>> password it just goes back to login. I am at a loss as to what to
>>> do to fix this one.
>> That sounds like a really weird problem. FreeBSD and the
>> ports (which portmaster deals with) are separated systems,
>> so even if you totally hose your ports, the OS should not
>> be affected.
> I'm well aware of this, and is also why I no clue what could have
> happened. It would never have occured to me that updating a port that
> has to do with audio and video containers would totally leave me unable
> to login into my system or issue and shell commands without getting
> a segmentation fault.
> I did discover that my / file system had run out of space -131MB.
> I'm still able to issue sudo, so using sudo rm -r I was able to free up
> 25GB...but still, /bin/sh, ls, clear all seg fault and su doesn't work
> and switching consoles doesn't let me log in.
> I maybe be left with attempting a single user boot, but I'm still not
> that comfortable at attempting such as I don't want to have a totally
> useless box.

Have you tried /rescue/sh? If that fails as well I'd start worrying 
about hardware problems.

More information about the freebsd-questions mailing list