removing /var/empty on a non-system disk

Polytropon freebsd at
Fri May 25 20:21:29 UTC 2012

On Fri, 25 May 2012 14:04:50 -0600, Gary Aitken wrote:
> something I'm not seeing
> I've got a disk previously used as a sys disk I'm trying to clean up.
> What's the key to removing /var/empty?
> 280 /hd1/var#sysctl kern.securelevel
> kern.securelevel: -1
> 281 /hd1/var#ls -l
> total 4
> dr-xr-xr-x  2 root  wheel  512 Jan  3 00:55 empty
> 282 /hd1/var#chflags noschg empty
> 283 /hd1/var#chmod 777 empty
> chmod: empty: Operation not permitted
> 284 /hd1/var#rmdir empty
> rmdir: empty: Operation not permitted

Interesting, I just tried this on my home system (FreeBSD 8.2-STABLE)
and it worked as intended. I did use the exact commands,
same securelevel.

Use the -o option for ls (ls -lo) to check on the effect
of chflags and chmod.

Without eexamining this behaviour in more detail, how about
this approach? Unmount the former system disk and newfs it?
That should "solve" the problem. :-)

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list