multiple versions of pcre needed with pkgs and ports

Gary Aitken freebsd at
Thu May 24 16:38:04 UTC 2012

I had an old version of ports and installed xorg and gnome2-lite using 
pkg_add.  Then tried to build (make) openoffice-3.  The make croaked 
with some missing java licensing files which were old.

So... I updated the ports tree via
   portsnap fetch
   portsnap extract
   portsnap update

Following that, an attempt to make openoffice-3 croaks because xorg and 
gnome2-lite installed pcre-8.20 and the oo make requires pcre-8.30_2.

Deleted packages using
   pkg_delete -drv pcre-8.20

Reinstalled xorg using pkg_add, which unfortunately reinstalled 
pcre-8.20.  I was expecting it to pick up the more recent one.

I expected the portsnap update to update packages to a point where they 
would be using the more recent pcre.


1.  If a package depends on an old version of another package, is it 
generally supposed to work with a newer version?

2.  Will the xorg package work with pcre-8.30_2 if I install that first?
     If not, should building the port instead work?

3.  I tried doing
       pkg_delete -f pcre-8.20
       cd devel/pcre
       make              (built 8.30_2)
       make install
     X still came up but gnome2 didn't.
     I'm pretty sure core x doesn't require pcre, but whatever part of 
the xorg package that does use it will croak when the time comes.

4.  As a result of 3, are the dependency counts in the package 
registration process all screwed up?

5.  If packages depending on older versions of pcre won't work with a 
newer version and a different port requires a newer version, how do you 
accomplish that?  Will building the older port, instead of installing 
the package for it, generally allow the older port and the one requiring 
the newer version of pcre to co-exist?

6.  What am I doing wrong?  Surely there's a way to get both xorg and oo 
on the same system...

Side issue:
   The pkg_delete occasionally stopped to ask whether or not to delete a 
file with mode 555.  Despite being nervous about it, I said yes and it 
seemed to cause no problems.  Any particular reason these are installed 
555, since they are part of an add-on package?  Don't have the names, 

Thanks for any insights,


More information about the freebsd-questions mailing list