no X after updating ports [Intel i945GME]

Joe Gain joe.gain at gmail.com
Wed May 23 14:37:43 UTC 2012


Hi all,

same problem here as well. Apparently this is in relation to updating
Cairo. See the thread on the forum:
http://forums.freebsd.org/showthread.php?p=178116

=> downgrade Cairo to 1.10
http://www.freebsd.org/cgi/cvsweb.cgi/ports/graphics/cairo/distinfo

Would be good to see this fixed ;)

On Wed, May 23, 2012 at 2:24 PM, Ramiro Caso <ramirocaso05 at yahoo.com.ar> wrote:
> On 21/05/2012 23:23, Antonio Olivares wrote:
>>
>> Dear folks,
>>
>> I have an acer-aspire 1 netbook running FreeBSD 9.0 i386.  It was
>> working beautifully, but after todays updates, X no longer works.
>
>
> I have a similar problem. I have a Dell Inspiron 1318 running 9.0 amd. I use
> KDE4 (kde-4.7.4_1). After an upgrade of ports (using portupgrade), X works,
> but every time I launch a non-KDE application, X crashes. Putting "vesa"
> instead of "intel" in xorg.conf stopped the crashes.
>
> I upgraded roughly the same ports, and I get a "Segmentation fault: 11 at
> address 0x10" error. The card is an Intel Mobile GM965/GL960 IGC.
>
> If it helps, I can provide more details (upgraded ports, log files and
> screen output).
>
>
>> On screen I have
>>
>> drm0:<Intel i945GME>  on vgapci0
>> info:  [drm] AGP at 0x20000000 256MB
>> info:  [drm] Initialized i915 1.6.0 20080730
>>
>> I have also:
>> xfsettingsd:  Fatal IO error 35 (Resource temporarily unavailable) on
>> X server :0.
>> xfce4-settings-helper:  Fatal IO error 35 (Resource temporarily
>> unavailable) on X server :0.
>> xfwm4:  Fatal IO error 35 (Resource temporarily unavailable) on X server
>> :0.
>> Thunar:  Fatal IO error 35 (Resource temporarily unavailable) on X server
>> :0.
>> wrapper:  Fatal IO error 35 (Resource temporarily unavailable) on X server
>> :0.
>> xfce4-panel:  Fatal IO error 35 (Resource temporarily unavailable) on
>> X server :0.
>> gkrellm:  Fatal IO error 0 (No error:  0) on X server :0.
>> running 'ssh-agent -s -k'
>> unset SSH_AUTH_SOCK;
>> unset SSH_AGENT_PID;
>> echo Agent pid 1785 killed;
>> xinit connection to X server lost
>>
>> waiting for X server to shut down xfdesktop:  Fatal IO error 2 (No
>> such file or directory) on X server :0.0.
>>
>>
>> Segmentation fault:  11 at address 0x10
>>
>> Fatal server errror:
>> Caught signal 11 (Segmentation fault:  11). Server aborting
>>
>> updates installed via portmaster:
>>
>> fontconfig-2.9.0,1
>> gdk-pixbuf-2.23.5_2
>> gtk-2.24.6_1
>>
>> also cairo went from cairo-1.10.2_3,1 to cairo-1.12.2,1
>>
>> Any advice, comments or suggestions are greatly appreciated.
>>
>> Best Regards,
>>
>>
>> Antonio
>> _______________________________________________
>> freebsd-questions at freebsd.org mailing list
>> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
>> To unsubscribe, send any mail to
>> "freebsd-questions-unsubscribe at freebsd.org"
>
>
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"



-- 
joe gain

jacob-burckhardt-str. 16
78464 konstanz
germany

+49 (0)7531 60389

(...otherwise in ???)


More information about the freebsd-questions mailing list