ATI Radeon HD5500 driver question

Gary Aitken freebsd at dreamchaser.org
Sat May 19 17:59:04 UTC 2012


Ok...  I tried the xf86-video-radeonhd driver, to no avail.
Then tried xf86-video-ati-6.14.3 with marginally better results.

Using the ati driver, which reports that it works for the HD5500, Xorg 
hobbles and writes a config file.
When it attempts to start, the log shows a boatload of information 
stuff, a few warnings, and finally

(EE) RADEON(0): Acceleration initialization failed
(II) Acceleration disabled

After which I'm left with the tail of the log file on the display,
but no prompt, and X is still running.

That is the only EE posted.

Questions:

1.  Since the driver notes that Acceleration was disabled, but there are 
no other errors, shouldn't the driver work in dumb frame buffer mode? 
(Hoping to get something hobbling along...)  Or is this the result of 
the need for KMS and I'm SOL?

2.  Since the server didn't exit, is it actually pretending to run? 
Shouldn't I be seeing the standard X grey hatched background?  Or is the 
server running, but the driver isn't passing bits on appropriately?

3.  The Xorg man page notes that <ctrl><alt><bksp> should cause it to 
exit.  However, it doesn't, and I had to use kill -TERM.  Any hints on 
why <ctrl><alt><bksp> doesn't cause it to exit?


On 5/19/2012 8:00 AM, Warren Block wrote:
> On Fri, 18 May 2012, Gary Aitken wrote:
>
>> Trying to set up a new box 9.0-RELEASE w/ X; has ATI Radeon HD5500 card.
>>
>> X.org -config says:
>> Missing output drivers. Configuration failed.
>>
>> From X.org I see one is supposed to get linux drivers from ati/amd,
>> but this info is over 2 years old and
>> http://support.amd.com/us/gpudownload/Pages/index.aspx
>> only allows choices of drivers for windoze.
>>
>> Can anyone point me to a useable driver, or if these cards are
>> essentially unusable, make a suggestion for a reliable card suitable
>> for non-gaming (2-D) X work?
>
> The radeon driver wants KMS for cards later than the 4000 series. A few
> of the 5000 series may somewhat work with the existing UMS driver, but
> most do not.
>
> KMS for Intel video is being worked on and already being used, but AFAIK
> work has not even begun for the Radeons.
>
>> Should one use an Nvidia card with the Linux 295.53 driver?
>
> A Radeon 4650 works fine with the current radeon driver. The Nvidia
> cards are faster with the FreeBSD version of their proprietary driver,
> ...but it's a proprietary driver.
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to
> "freebsd-questions-unsubscribe at freebsd.org"
>
>
>



More information about the freebsd-questions mailing list