buildworld problem

Andriy Babiy AndriyBabiy at
Sat May 19 09:03:06 UTC 2012

> > FreeBSD myhost 9.0-RELEASE FreeBSD 9.0-RELEASE #0: Fri Mar 23
> > 20:00:59 PDT 2012     root at myhost:/usr/obj/usr/src/sys/GENERIC
> > amd64
> >
> > root#cd /usr/obj
> > root#chflags -R noschg *
> > root#rm -rf *
> > root#make buildworld
> > ...
> > cd /usr/src; MACHINE=i386 MACHINE_ARCH=i386  MACHINE_CPU="i686 mmx
> > sse sse2"  LD="ld -m elf_i386_fbsd -Y
> > P,/usr/obj/usr/src/lib32/usr/lib32" AS="as --32"
> > MAKEOBJDIRPREFIX=/usr/obj/lib32
>      I may be going over my head on this one:-)
>      However to my understanding it seems,  it is trying to build 32
> bit on a amd 64bit install?

Since 7.0 I upgraded this machine via buildworld. It was always amd64.
As you see in uname output, I upgraded it from 8.X to 9.0 with no
problem. Time/date is in sync. I don't see any problems in the system I
am running, but I got latest code changes for SSL and wanted to do as
usual per instructions. On i386 machine everything worked fine, and I
don't suspect the code changes are causing it; there must be something
simple I miss.
In make.conf I have CPUTYPE=nocona and perl version, and obviously
clang related definitions.
In the error above I see -DCOMPAT_32 string which might be the case for
building 32 compatibility libraries for amd64, but it still doesn't
explain what fails and why.
Any ideas?
Thank you.

More information about the freebsd-questions mailing list