Performance and mouse problems

Albert Shih Albert.Shih at
Fri May 4 12:51:40 UTC 2012

 Le 02/05/2012 ? 22:44:19+0200, Jerome Herman a écrit
> Ok here is what happens,
> In your system you have your touchpad declared both in a static way in 
> your xorg config, and probed by HAL.
> What happens is that when xorg starts it first install the touchpad as 
> required by the config file, and then tries to install it again via 
> autodetection. Of course the second installation of the same device 
> doesn't work as the device is already busy with xorg, and xorg stops to 
> try to auto-install devices.
> When you plug another mouse, xorg is notified that there are new 
> devices, but starts by trying to reinstall the touchpad, fails again for 
> the same reason as above and stops trying.
> In order to solve your problem you can try the following :
> a) remove the touchpad lines from your xorg config. This way the 
> touchpad should be installed by auto detection. (simply comment it as 
> you might be needing it back soon)
> b) forbid hal from probing the touchpad. If solution a fails, I would 
> explain to you how to do this if solution a) fails.

I try this.  

I do a hal-device find the unique udi to have /dev/psm0  in input.device,

 udi = '/org/freedesktop/Hal/devices/psm_0'
  freebsd.driver = 'psm'  (string)
  freebsd.unit = 0  (0x0)  (int) = 'psm.0'  (string)
  freebsd.device_file = '/dev/psm0'  (string)
  info.capabilities = { 'input', 'input.mouse' } (string list)
  info.category = 'input'  (string)
  input.device = '/dev/psm0'  (string)
  input.x11_driver = 'mouse'  (string)
  info.addons = { 'hald-addon-mouse-sysmouse' } (string list)
  info.udi = '/org/freedesktop/Hal/devices/psm_0'  (string)
  info.parent = '/org/freedesktop/Hal/devices/atkbdc_0'  (string)
  info.product = 'PS/2 Mouse'  (string)
  info.subsystem = 'platform'  (string)

and add a new file in /usr/local/etc/hal/fdi/policy/ with

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
      <match key="info.product" string="PS/2 Mouse">
        <merge key="info.ignore" type="bool">true</merge>

restart hald, reboot and...nothing :-( 

I've try also with something like 

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
     <match key="freebsd.driver" string="psm">
      <match key="info.product" string="PS/2 Mouse">
        <merge key="info.ignore" type="bool">true</merge>

but same result.

The touchpad still working and most important the mouse still NOT working.

Any help ? 



Albert SHIH
DIO bâtiment 15
Observatoire de Paris
5 Place Jules Janssen
92195 Meudon Cedex
Téléphone : 01 45 07 76 26/06 86 69 95 71
xmpp: jas at
Heure local/Local time:
ven 4 mai 2012 14:42:00 CEST

More information about the freebsd-questions mailing list