USB Logitech QuickCam Ultra Vision

Da Rock freebsd-questions at
Fri Mar 2 15:33:26 UTC 2012

On 03/03/12 00:08, sean wrote:
> On 03/02/12 07:43, Da Rock wrote:
>> On 03/02/12 22:31, sean wrote:
>>> On 03/02/12 01:04, Matthias Apitz wrote:
>>>> El día Friday, March 02, 2012 a las 05:48:11AM +0100, Daniel C. 
>>>> Dowse escribió:
>>>>> Hi,
>>>>> usbconfig -d ugenX.Y do_request 0x22 0x01 0x100 0x86 0x03 0x80 
>>>>> 0xBB 0x00
>>>>> usbconfig -d ugenX.Y reset
>>>>> usbconfig -d ugenX.Y do_request 0x22 0x01 0x100 0x86 0x03 0x80 
>>>>> 0xBB 0x00
>>>>> and then restart webcamd.
>>>>> may help, it worked on my Logitech Business Pro Cam
>>>>> cheers
>>>> FWHIW, such quirks are also shown in 
>>>> and once your webcam is working fine it could show up there too;
>>>> HIH
>>>>     matthias
>>> Installed devices:
>>> pcm0: <AMD-8111> (play/rec) default
>>> pcm1: <USB audio> (rec)
>> Bang! There it is. pcm1 - see the (rec) following it?
>> Adjust the levels using `mixer -f /dev/mixer1` and away you go, happy 
>> conferencing ;)
> Well I adjusted the volume as you pointed out, still no luck.
> Currently I am thinking I might need to get the usbconfig command 
> above to now work, but it gives a nondescript error.
> tardis# usbconfig
> ugen4.2: <product 0x08c9 vendor 0x046d> at usbus4, cfg=0 md=HOST 
> spd=HIGH (480Mbps) pwr=ON
> tardis# lsusb
> Bus /dev/usb Device /dev/ugen4.2: ID 046d:08c9 Logitech, Inc. QuickCam 
> Ultra Vision
> tardis# usbconfig -d ugen4.2 do_request 0x22 0x01 0x100 0x86 0x03 0x80 
> 0xBB 0x00
> tardis#
> I have looked at the man pages in trying to figure out exactly what 
> the eight number sets after do-request are doing, thinking that I 
> might have to adjust them for some reason. I am also starting to 
> wonder if my camera mic will work with Skype.
> I ran the mic test listed on the webcam site, 
> .
> tardis# dd if=/dev/dsp1.0 of=/dev/dsp0.0 bs=64
> ^C1073+0 records in
> 1073+0 records out
> 68672 bytes transferred in 8.571198 secs (8012 bytes/sec)
> tardis#
> The test works, the mic picked me up and played it through the 
> speakers, with some nasty loop feedback, but it did work.
Yes, unfortunately you have to use headphones or switch the mic off- 
caused me no end of issues with recording hunting for a hidden mic 
pickup in the settings ;)

I'm not 100% sure how skype works myself, but does it have a audio 
settings list? Where do you tell it where to output audio? It should 
offer an option for input too. I don't know if your usbconfig actually 
needs tweaking of you can pick up sound. Maybe check your LD environment 

More information about the freebsd-questions mailing list