USB system: FreeBSD 9-STABLE and 10-CURRENT do not recognize 64GB USB drive while Linux and Windows do

Thomas Mueller mueller23 at
Sun Jun 24 09:59:36 UTC 2012

> Hi,

> On Saturday 23 June 2012 15:08:53 Thomas Mueller wrote:

> > I don't think I ever tried to connect a USB 2.0 device to 3.0 port, but I
> > tried the opposite.

> I have here 2 hard disks and 2 flash drives with USB 2.0. Three of them work
> on FreeBSD on an USB 3.0 port. One hard disk only works on a USB 3.0 port.

> One hard drive with USB 3.0 does not work on USB 3.0 but only on 2.0.

> Irony is that the PCBSD installer installed PCBSD on the USB 3.0 disk but it
> did not boot afterward.

> > I tried to access that USB 3.0 hard drive on the new computer from USB 2.0
> > port because NetBSD has no USB 3.0 support: no go.

> Let me check this out.

> > But when I installed USB 2.0 brackets to USB 2.0 headers on the
> > motherboard, the USB 3.0 hard drive was accessible from those USB 2.0
> > ports.

> Same as in my case.

> USB is more a lottery than real computing for me.

> Erich

I suppose I could say NetBSD is more a lottery than real computing, especially on the new computer.

But some of the bugs are consistent.

My USB 3.0 hard drive is not bootable (motherboard issue?), also does not show on Grub2 Super Grub Disk on the System Rescue CD menu

Maybe the latter could be fixed by building Grub2 from source under either Linux or FreeBSD Ports.

I think I'd also like to build the gdisk port, both on main hard drive and on a bootable FreeBSD USB stick.

One USB stick (PNY 1 GB) is no longer readable/mountable from FreeBSD though it is from Linux.

I thought that might be corruption.  Since I have all that data now on an Ativa 4 GB USB stick, I could install the latest System Rescue CD to the PNY 1 GB USB stick (runs Linux on FAT32), see if there are any problems.


More information about the freebsd-questions mailing list