USB system: FreeBSD 9-STABLE and 10-CURRENT do not recognize 64GB USB drive while Linux and Windows do

Thomas Mueller mueller23 at
Sat Jun 23 08:08:59 UTC 2012

> My elder colleague often told me that it is the easiest and well-working way
> to check whether the one is certified to work for Mac OS X to get USB mass
> storage devices which work with *BSD :)

> Just my 5 yen,

-|-__   YAMAMOTO, Taku
 | __ <     <taku at>

What if a USB mass storage device works with some BSDs but not all?

I had Kingston Data Travelers, 2 GB, from one lot that were good with Linux and FreeBSD but not NetBSD.

Other USB sticks, including Kingston Data Tavelers, worked with Linux, FreeBSD and NetBSD.

I even installed FreeDOS 1.1 prerelease on one of those NetBSD-averse Kingstom Data Travelers.

But I think either Mac OS X, Linux or FreeBSD is much more production-ready than NetBSD.

> There are 3 drivers, one for 3.0, 2.0 and 1.0, and they are associated to
> corresponding devices  at boot. I'll play around with it this weekend and
> see how to switch, i've also noticed issue connecting 2.0 device to 3.0
> port.

> Waitman Gobble
> San Jose California USA

I don't think I ever tried to connect a USB 2.0 device to 3.0 port, but I tried the opposite.

My Western Digital My Book Essential 3.0 TB USB 3.0 drive works even on the old computer whose motherboard's USB is 1.1.

I tried to access that USB 3.0 hard drive on the new computer from USB 2.0 port because NetBSD has no USB 3.0 support: no go.

But when I installed USB 2.0 brackets to USB 2.0 headers on the motherboard, the USB 3.0 hard drive was accessible from those USB 2.0 ports.


More information about the freebsd-questions mailing list