USB system: FreeBSD 9-STABLE and 10-CURRENT do not recognize 64GB USB drive while Linux and Windows do

O. Hartmann ohartman at
Sat Jun 23 07:21:42 UTC 2012

On 06/22/12 08:22, Hans Petter Selasky wrote:
> On Friday 22 June 2012 08:01:38 O. Hartmann wrote:
>> I have a USB drive/stick, Lexar USB Flash drive as reported by FreeBSD
>> shown below.
>> When first used, I was able to put approx. 30 GB of data on it - it was
>> visible to FreeBSD 9 and 10 as expected.
>> A Linux system at the lab was also capable of recognizing it. After
>> that, I tried to operate on the stick on a Notebook, FreeBSD 9, and
>> another station, FreeBSD 10. But FreeBSD didn't recognize the USB drive
>> anymore - sometimes, but this seems to be a gambling issue :-(
>> Trying Linux on different hardware platforms and even those machines
>> prior not recognizing the USB drive do recognize the drive as Lexar USB
>> Flash drive with 64GB. That is Suse Linux (some 12.XX), that is Ubuntu
>> 12.04, that is Windows 7 Pro/x64. I can format the drive, I can push and
>> pull data from it.
>> So, since the USB drive won't work with three different FreeBSD boxes
>> (one running 9-STABLE, two 10-CURRENT, all systems most recent sources
>> and buildworld from a day ago).
>> I suspect either a weird configuration issue I use on all platforms in
>> questions in common triggering the weird beviour - or FreeBSD is simply
>> incapable of handling the 64GB drive. I do not have issues with USB
>> drives with capacities of 32, 8 or 4 GB of different brands.
>> As shown in the portion of the dmesg below, the USB drive is recognized
>> physically. It doesn't matter whether USB port I use (I tried all
>> available on all boxes and in most cases I use a Dell UltraSharp powered
>> in-screen HUB). Since other OSes handle the drive as expected, I exclude
>> hardware issues.
>> All FreeBSD in common is the fact I use the new device ahaci/device ata
>> CAM/ATA scheme with devcie scbus in the kernel (I use custom kernels!).
>> Apart from trying a GENERIC kernel (which is next I will do this
>> weekend), does anyone have similar experiences and probably solutions?
>> Regards,
>> oh
>> ugen7.6: <Lexar> at usbus7
>> umass1: <Lexar USB Flash Drive, class 0/0, rev 2.00/11.00, addr 6> on
>> usbus7 (probe0:umass-sim1:1:0:0): INQUIRY. CDB: 12 0 0 0 24 0
>> (probe0:umass-sim1:1:0:0): CAM status: CCB request completed with an error
>> (probe0:umass-sim1:1:0:0): Retrying command
>> (probe0:umass-sim1:1:0:0): INQUIRY. CDB: 12 0 0 0 24 0
>> (probe0:umass-sim1:1:0:0): CAM status: CCB request completed with an error
>> (probe0:umass-sim1:1:0:0): Retrying command
>> (probe0:umass-sim1:1:0:0): INQUIRY. CDB: 12 0 0 0 24 0
>> (probe0:umass-sim1:1:0:0): CAM status: CCB request completed with an error
>> (probe0:umass-sim1:1:0:0): Retrying command
>> (probe0:umass-sim1:1:0:0): INQUIRY. CDB: 12 0 0 0 24 0
>> (probe0:umass-sim1:1:0:0): CAM status: CCB request completed with an error
>> (probe0:umass-sim1:1:0:0): Retrying command
>> (probe0:umass-sim1:1:0:0): INQUIRY. CDB: 12 0 0 0 24 0
>> (probe0:umass-sim1:1:0:0): CAM status: CCB request completed with an error
>> (probe0:umass-sim1:1:0:0): Error 5, Retries exhausted
> Hi,
> After plugging the device, try:
> usbconfig -d 7.6 add_quirk UQ_MSC_NO_INQUIRY
> Then re-plug it.
> I'm sorry to say a lot of USB flash sticks out there are broken and only 
> tested with the timing of MS Windows. Part of the problem is that it is 
> difficult to autodetect these issues, because once you trigger the non-
> supported SCSI command, then the flash key stops working like you experience.
> I would be more than glad to open up an office to certify USB devices for use 
> with FreeBSD :-)
> --HPS

I tried the USB drive this morning with the recommended quirk shown
above on FreeBSD 10.0-CURRENT #1 r237462: Sat Jun 23 01:00:35 CEST 2012
without success. I get the same error message as shown above. With or
without quirk.

I then started Windows 7 on the same box. The USB drive is seen as
expected and reflects what I experienced on every other non-FreeBSD box
and hardware in the lab on last week.
I reformatted the USB drive with extFAT and standard block size on
Windows 7. The USB drive is now seen again on FreeBSD and recognized as
a drive. "Seen" in my sloppy terminology means: recognized as a disk.
The hardware is recognized, but it is not recognized as a drive.

The fact, that the very first time after I bought that USB drive, I was
able to put several GB on it, use it on both FreeBSD 9-STABLE and
10-CURRENT, and then it broke, drives me nuts.
Using the very same pen drive on other OSes even on the same hardware
without issues makes me believe FreeBSD does have an issue, not the USB

I will fill the USB drive with data and try to use it very often on
FreeBSD. Last time the error occured, it was read by a Suse Linux box.
If I wouldn't know better I would say Linux tries to kill the USB drive
... But Linux did see it all the time. A "usual customer" would see it
the same way, I guess.

I will test and report next week when I have access to the other boxes
and OSes again.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: OpenPGP digital signature
Url :

More information about the freebsd-questions mailing list