USB system: FreeBSD 9-STABLE and 10-CURRENT do not recognize 64GB USB drive while Linux and Windows do

Garrett Cooper yanegomi at
Fri Jun 22 06:22:36 UTC 2012

On Thu, Jun 21, 2012 at 11:01 PM, O. Hartmann
<ohartman at> wrote:
> I have a USB drive/stick, Lexar USB Flash drive as reported by FreeBSD
> shown below.
> When first used, I was able to put approx. 30 GB of data on it - it was
> visible to FreeBSD 9 and 10 as expected.
> A Linux system at the lab was also capable of recognizing it. After
> that, I tried to operate on the stick on a Notebook, FreeBSD 9, and
> another station, FreeBSD 10. But FreeBSD didn't recognize the USB drive
> anymore - sometimes, but this seems to be a gambling issue :-(
> Trying Linux on different hardware platforms and even those machines
> prior not recognizing the USB drive do recognize the drive as Lexar USB
> Flash drive with 64GB. That is Suse Linux (some 12.XX), that is Ubuntu
> 12.04, that is Windows 7 Pro/x64. I can format the drive, I can push and
> pull data from it.
> So, since the USB drive won't work with three different FreeBSD boxes
> (one running 9-STABLE, two 10-CURRENT, all systems most recent sources
> and buildworld from a day ago).
> I suspect either a weird configuration issue I use on all platforms in
> questions in common triggering the weird beviour - or FreeBSD is simply
> incapable of handling the 64GB drive. I do not have issues with USB
> drives with capacities of 32, 8 or 4 GB of different brands.
> As shown in the portion of the dmesg below, the USB drive is recognized
> physically. It doesn't matter whether USB port I use (I tried all
> available on all boxes and in most cases I use a Dell UltraSharp powered
> in-screen HUB). Since other OSes handle the drive as expected, I exclude
> hardware issues.
> All FreeBSD in common is the fact I use the new device ahaci/device ata
> CAM/ATA scheme with devcie scbus in the kernel (I use custom kernels!).
> Apart from trying a GENERIC kernel (which is next I will do this
> weekend), does anyone have similar experiences and probably solutions?

    I don't personally have any relevant experience with this device,
but having the exact revisions of code where this was working and
where it was failing would be helpful, in order to perform a binary
search to determine whether or not this is a regression.

More information about the freebsd-questions mailing list