Booting from ZFS with serial console

Brian McCann bjmccann at
Mon Jun 11 19:53:45 UTC 2012

Hi all.  I am in desperate need of some help with ZFS (maybe GPT) and
serial consoles.  I use 19200 for my console speed for everything, so I
recompiled the boot blocks using "BOOT_COMCONSOLE_SPEED="19200" " in
/etc/make.conf.  I then ran this to install new blocks to my two drives in
the mirror pair:

gpart bootcode -b /boot/pmbr -p /boot/gptzfsboot -i 1 ad4
gpart bootcode -b /boot/pmbr -p /boot/gptzfsboot -i 1 ad6

If the keyboard is plugged in when the machine starts up, all is good.
 With the keyboard unplugged, I get a small error "dump" followed by "BTX

I tried this with the files from the install DVD, and the same thing
happens..."BTX Halted" without a keyboard plugged in.

In both cases, /boot.config has : "-P -S19200".  I tried changing it to
"-Dh -S19200", and I get the "BTX Halted" on every boot now.

Can someone please shed some light on why it's crashing like this?  I'm
fairly confident this behavior is a bug and not "by design"...but I can't
believe that this bug would not be noticed up until now.


Brian McCann

"I don't have to take this abuse from you -- I've got hundreds of
people waiting to abuse me."
                -- Bill Murray, "Ghostbusters"

More information about the freebsd-questions mailing list