Problems with portupgrade libreoffice

Walter Hurry walterhurry at
Sun Jun 10 08:01:00 UTC 2012

On Sat, 09 Jun 2012 20:46:49 +0000, Walter Hurry wrote:

> On Sat, 09 Jun 2012 18:12:25 +0100, Dave Morgan wrote:
>> On 09/06/12 at 04:41P, Walter Hurry wrote:
>>> FreeBSD 9 on x86_64.
>>> I am in the process of doing a portupgrade on libreoffice (from 3.4.4
>>> to During the build it has (so far) errored out 4 times, in
>>> the following modules:
>>> vcl framework sfx2 tail_build
>>> Each time, it told me to go into the subdirectory, do a gmake clean
>>> and a gmake -r there, then return to the top level and rerun make.
>>> This I duly did, but to my surprise, each time I ran the gmake -r, it
>>> completed successfully.
>>> When the top-level make finally succeeds, I intend simply to rerun the
>>> portupgrade, on the theory that seeing everything already made, it
>>> will just do the uninstall/reinstall, sort out the dependencies and so
>>> forth.
>>> Q1) Is this a sensible approach?
>>> Q2) Has anyone else seen this? What is going on?
>> There is a thread in the forums which recommends removing boost-libs
>> and boost-jam, building libreoffice then reinstalling them.
>> I did this and it worked for me.
> Thanks. I'll try that and report back.

Yes, that did the trick. It zoomed through!
Very many thanks. I'll need to keep an eye on the forum, methinks.

More information about the freebsd-questions mailing list