mount failure

Gary Aitken freebsd at
Thu Jun 7 05:40:38 UTC 2012

Running under X with xfce, just did this:

  gpart show -l da0
  gpart delete -i 1 da0
  gpart destroy da0
  gpart create -s GPT da0
  gpart bootcode -b /boot/pmbr da0
  gpart add -t freebsd-boot -i 1 -s 512K -l gptboot da0
  gpart bootcode -b /boot/gptboot -i 1 da0
  gpart add -t freebsd-ufs -a 4K -s 35G -i 2 -l fbsdroot da0
  gpart add -t freebsd-swap -a 4K -s 512M -i 3 -l fbsdswap da0
  gpart add -t freebsd-ufs -a 4K -s 1G -i 4 -l fbsdvar da0
  gpart add -t freebsd-ufs -a 4K -s 512M -i 5 -l fbsdtmp da0
  gpart add -t freebsd-ufs -a 4K -s 893G -i 6 -l fbsdusr da0
  newfs /dev/gpt/fbsdroot
  newfs -U /dev/gpt/fbsdvar
  newfs -U /dev/gpt/fbsdtmp
  newfs -U /dev/gpt/fbsdusr
  mount /dev/gpt/fbsdroot /mnt/goflex

I then tried to create a snapshot of /
X immediately slowed to less than a crawl, and I couldn't do anything.
At first I could move the pointer a little, but then I lost it.
After a half hour or so, I power-cycled and rebooted.

When I tried to mount the usb drive, I (not surprisingly) got this:

  #mount /dev/gpt/fbsdroot /mnt/goflex/root
  mount: /dev/gpt/fbsdroot : operation not permitted
  WARNING: RW mount of /mnt/goflex denied.  File system is not clean - run fsck.

But when I try to do an fsck, I can't:
  #fsck /dev/gpt/fbsdroot
  fsdk: could not determine filesystem type
(same msg for /dev/gpt and /dev/da0p2)


More information about the freebsd-questions mailing list