umount device busy

Robert Bonomi bonomi at
Sun Jun 3 16:07:29 UTC 2012

Gary Aitken <freebsd at> wrote:
> Something I'm overlooking here and a lot of questions I can't seem to find the answers to...
> I mounted a usb drive
>   mount -t ntfs /dev/da0s1 /mnt/goflex 
> Then, as nearly as I can remember...
>   I then poked around a bit using the xfce4 browser.
>   I tried to mkdir from the mount point as a normal user:
>     cd /mnt/goflex
>     %mkdir breakaway
>     mkdir: .: No such file or directory
>   After checking write premissions, which I didn't have,
>   I did an su -l and tried again, with the same results.
> Questions:
> 1.  What does the "No such file or directory" mean from mkdir?
>     It's a relative dir name, and I'm sitting at a valid dir.

The specific complaint was concerning '.'  this indicates a filesystem
error.  Note: it is (or, at least 'used to be') documented that _writing_
to NTFS filesystems was likely to have problems.
> 2.  How do I find out how the file-system was mounted?
>     mount (noargs) does not show read/write status

Yes, it does. :)

'readonly' means just that.  'readonly' NOT shown means read/write.

> 6.  And finally, any idea why umount says the device is busy?


You did a cd to a directory located on that device.
you started a 'su' process.

Maybe you did a cd to 'somewhere else', or maybe not.

Then you tried to umount the device.

The current process may have the 'working directory' open on that drive.

The _PARENT_ of the su process *DOES* have the 'working directory' open there.

The O/S rightly refuses to unmount the device in such a situation. :)

More information about the freebsd-questions mailing list