How to use an external USB3.0 drive with 4k sectors?

Jens Schweikhardt schweikh at
Sat Jun 2 18:22:09 UTC 2012

On Thu, May 31, 2012 at 08:26:21PM +0200, Damien Fleuriot wrote:
# > When I plug it to one of the two USB3.0 ports (using the xhci driver), I
# > don't get device nodes in /dev created for it, but instead an ever
# > growing list of
# > 
# >    ugen4.2: <Jmicron Corp.> at usbus4
# >    umass2: <Jmicron Corp. Usb production, class 0/0, rev 2.10/1.00, addr 1> on usbus4
# >    ugen4.2: <Jmicron Corp.> at usbus4 (disconnected)
# >    umass2: at uhub4, port 4, addr 1 (disconnected)
# > 
# > The USB3.0 ports otherwise work fine with a 16BG USB3.0 Stick. Windows 7
# > can use the disk as well on the USB3.0 port, which makes me look for
# > things I have missed. For example, my kernel config is stripped down
# > quite a bit, so it might be that my custom kernel does not have all the
# > necessary drivers built in or kldloaded. Do I need "device ada"? What is
# > the magic needed to hook up 4k secotr drives via USB3.0?
# > 
# > Regards,
# > 
# >    Jens
# Logic dictates that you try with GENERIC, see if that works any better ;)

I tried with a GENERIC from -CURRENT, the detection message is somewhat different:

ugen4.2: <vendor 0x152d> at usbus4
umass0:   SCSI over Bulk-Only; quirks = 0x0100
umass0:10:0:-1: Attached to scbus10

However still no device nodes, AFAICT. Using "camcontrol rescan all"
followed by "camcontrol devlist" does not show the drive.

Any chance I can get this drive going on USB 3? Could the
problem be the quirk = 0x0100?


Jens Schweikhardt
SIGSIG -- signature too long (core dumped)

More information about the freebsd-questions mailing list