FreeBSD on the ASUS P8H67-M LGA1155 H67 motherboard

Victor Sudakov vas at
Sat Jun 2 16:40:29 UTC 2012

Wojciech Puchar wrote:
> > 2. It looses one of the HDDs during intensive read/write operations:
> >
> > Jun  2 00:55:33 vas kernel: ahcich1: Timeout on slot 4 port 0
> > Jun  2 00:55:33 vas kernel: ahcich1: is 00000000 cs 000000c0 ss 000000f0 rs 000000f0 tfd c0 serr 00000000 cmd 0000c617
> > Jun  2 00:56:48 vas kernel: ahcich1: Timeout on slot 0 port 0
> > Jun  2 00:56:48 vas kernel: ahcich1: is 00000000 cs 00000001 ss 00000000 rs 00000001 tfd c0 serr 00000000 cmd 0000c017
> > Jun  2 00:57:20 vas kernel: ahcich1: AHCI reset: device not ready after 31000ms (tfd = 00000080)
> >
> > I shall of course check the HDD and cable, but they worked flawlessly on
> > the previous system.
> well i've had such problems regularly with many motherboard. It happens 
> often when you have many disks and put heavy load on them. 

Indeed this happens under load. I would not call it particularly
heavy though, it's more like moving large files between zfs datasets
causes the loss of drive.

> And it is only 
> result of poor hardware (not sure - poor controller, motherboard design, 
> both?).
> i tried changing disks, ports, until i replaced this server with dell 
> poweredge ;)

Can we be sure that it is not a bug in the ahci or ada driver? Is
there a way to reinit and reattach the failed drive?

> if this is quite random, swapping ports change the behaviour but not 
> solve it, swapping cables does not, yet there is no real rule when and why 
> it happens you have same problem that i've had.

Could it have been a power problem?

> > 3. I had to run xorg in VESA mode, because xf86-video-intel-2.7.1_4 does
> > not recognize the video chip on the motherboard on question. That is a
> tried this from ports?
> drwxr-xr-x  2 root  wheel  512 18 maj 16:49 xf86-video-intel29

Yes, I have too. It says "no device detected" or something like that.
> depends of hardware model.
> actually intel GFX is the only one i tolerate and it works.
> Eg the one in my lenovo G550 laptop needs 2.7 driver, the one builtin in 
> Atom D525 processor needs 2.9 driver.
> Completely new intel GFX are not YET supported but that what i only 
> heard as i don't have any of them.

What video card would the collective mind of FreeBSD users recommend?
I'm not a gamer, this box runs FreeBSD only with a recent xorg, I
often watch movies on it.

Victor Sudakov,  VAS4-RIPE, VAS47-RIPN
sip:sudakov at

More information about the freebsd-questions mailing list