Corrections to: unable to upgrade to mysql55-server

Matthew Seaman matthew at
Fri Jun 1 06:00:26 UTC 2012

On 01/06/2012 00:32, Gene wrote:
> Actually, I did just as above except using portmanager.. Tried deleting the 
> two packages & tried again with portmaster. Still no luck. So I deleted them 
> again and installed from packages. mysql-client-5.4.. installed lib/mysql/
>, but mysql-server-5.4... wanted lib/mysql/
> Finally, after giving ritual sacrifice to the backup 
> gods, I went to the ZFS snapshots and just restored directories wholesale and 
> everything is working again albeit with previous versions of mysql (and 
> postfix which also gave me fits) but with the package database entries now 
> missing (for some strange reason, I hadn't been backing up that directory. 
> You'd think I'd learn - if it ain't broke, don't fix it. 

Something is definitely not right with your system.  It really shouldn't
be that painful.

The missing package database entries can usually be recovered by forcing
a reinstall of the package over what is already on disk, but if
everything is working properly, I wouldn't worry too much about the
contents of /var/db/pkg.

I'm thinking that having the registry of installed ports in a completely
separate partition or ZFS (ie /var) to where the ports are installed
(/usr/local) is not ideal, especially when using snapshots to provide a
roll-back capability.  /usr/local/var/db/pkg perhaps?

> Still wonder what went wrong though.... Seems every time I try to update any 
> ports, things get broken, ports don't compile, etc., etc., ad infinitum, ad 
> nauseum. I've got to be doing something wrong. Incidentally, portmaster, when 
> updating mysql54-server reliably rebooted the system. Hmmm....
> Anyone know if there is a good memory test utility that can be run on FBSD 
> AMD64?

Yes -- you could well be having hardware problems.  Try a few passes of
memtest86.  It's in ports, but it's a standalone application you boot
into so concepts of compatibility with particular OSes is irrelevant.

Also do the usual stuff removing any dust or fluff that may be clogging
up the ventilation holes or heatsinks, check that you've still got a
good thermal contact between the heatsink and CPU (replace thermal
compound if necessary).  Also make sure your power supply is up to the
job.  They can fade over time, or you may have added a peripheral too
far.  [Although generally if anything here was wrong, you'ld see the
machine crashing and rebooting rather than it affecting use of the ports...]



Dr Matthew J Seaman MA, D.Phil.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 267 bytes
Desc: OpenPGP digital signature
Url :

More information about the freebsd-questions mailing list