UPDATING 20120116 -- x11/xcb-util -- instructions not working

Michael Powell nightrecon at hotmail.com
Thu Jan 26 11:06:28 UTC 2012

Conrad J. Sabatier wrote:

> On Wed, 25 Jan 2012 08:53:39 -0600
> Mark Felder <feld at feld.me> wrote:
>> For the life of me I can't work around this xcb-util issue. This is
>> a pretty fresh install and I have not made any workaround symlinks.
>> I ran:
>> # portmaster -R -r xcb-util-0
>> And the problem persists. It didn't even complete all the packages
>> because some were still erroring on missing xcb libraries.
>> Example, editors/mousepad:
>> libtool: link: cannot find the library `/usr/local/lib/libxcb-aux.la'
>> or unhandled argument `/usr/local/lib/libxcb-aux.la'
>> gmake[2]: *** [mousepad] Error 1
> I'm getting this same error in several ports.  Just exactly which
> package is supposed to be providing libxcb-aux.la?  And why isn't it?

I'm not exactly certain about this, and so am probably wrong. I thought the 
'*.la' files were 'linker archives' created by libtool. But I never really 
got completely through the process of fully understanding exactly how all 
the autotools, make and gmake, and libtool operate.


More information about the freebsd-questions mailing list