NFSv4 "stronger authentication required" error

Joseph Lenox lordofhyphens at
Fri Jan 6 00:36:17 UTC 2012

I've run into a strange problem while trying to mount from FreeBSD 
9.0-RC3 to anything I can find using NFSv4.

The command I'm using is:

#mount -v gorkon:/dustbin /tmp/test

This returns the following immediate information on a Debian 6 Linux box:
mount: no type was given - I'll assume nfs because of the colon
mount.nfs: timeout set for Thu Jan  5 17:37:40 2012
mount.nfs: trying text-based options 
mount.nfs: mount(2): Permission denied
mount.nfs: access denied by server while mounting gorkon:/dustbin

There's no log entry that I can find on the server (gorkon), and the 
following log entry is in my syslog for the debian box:

[30082.224612] RPC: server gorkon requires stronger authentication.

The NFS server has nfsuserd running, rpcbind running. I've tried to set 
the share in /etc/exports to use sec=sys (and connect the same way). I 
don't have Kerberos set up on this network, and I'm not about to start. 
The Debian NFSv4 servers do connect to a Solaris 10 NFSv4 server, and 
the FreeBSD box can't mount its own shares over NFS if I force use of 
nfsv4 (error is mount_nfs: /tmp/test, : Permission denied). A FreeBSD 
8.2-RELEASE box won't mount either, same error.

The Solaris 10 box also cannot mount the FreeBSD box's mount. The error 
for this machine is :

genunix: [ID 664466 kern.notice]  NFS compound failed for server gorkon: 
error 7
genunix: [ID 532867 kern.warning] WARNING: NFS server initial call to 
gorkon failed: permission denied.

NFSv3 mounts work fine.

Anyone know what's going on?

More information about the freebsd-questions mailing list