Root password not working on console

Walt Elam wrelam at
Fri Aug 31 22:37:50 UTC 2012

I recently *accidentally* removed myself from the wheel group, so I was no
longer able to use su to root. To fix it, I hooked up a monitor and
keyboard to my FreeBSD 8.2 box so I could login as root, but it kept
rejecting my password. I restarted the machine in single-user mode, did the

mount -u /
mount -a

So it booted back in to multi-user mode. Once again, I tried to login as
root, but got the same "Login incorrect" message. Puzzled, I repeated the
previous steps using the password "pass" this time. However, I went ahead
and added my user account to the wheel group while in single-user mode.
Once in multi-user mode again, I still got "Login incorrect" (specifically,
pam_acct_mgmt(): authentication error) when logging in as root. I SSH'd to
the machine as my regular user, typed su, and entered "pass" which worked
just fine.

So, I have absolutely no clue why I am unable to login to my machine, on
the console, as root with "pass", but it works when using su from a regular
user account. I tried searching around but almost all of the hits are about
resetting the root password in single-user mode. Does any one know what I'm
doing incorrectly?

Thanks for any help in advance,


More information about the freebsd-questions mailing list