Apache FCGI in a a jail under FBSD 9 won't start due to shared memory creation error

Chad Leigh Shire.Net LLC chad at shire.net
Tue Aug 7 16:25:29 UTC 2012

Hi.  I'll try this again.

I run systems using FreeBSD 9.0

FreeBSD utah.XXXXXXXcom 9.0-STABLE FreeBSD 9.0-STABLE #1: Wed Mar 21 15:22:14 MDT 2012     chad at underhill:/usr/obj/usr/src/sys/UNDERHILL-XEN  amd64

and on those systems run a bunch of jails.  I have Apache 2.2 built and running in the jail in question, and recently had need to add mod_fcgid to it.  NOTE that the Apache and mod_fcgid were not installed through ports or packages.  I download the source and build myself (for various reasons).  

Apache inside the Jail, with mod_fcgid enabled will not start:

[Mon Jul 23 10:59:35 2012] [emerg] (78)Function not implemented: mod_fcgid: Can't create shared memory for size 1192488 bytes

I did a search on this and found that I would probably need a system kernel parameter changed from 0 -> 1


So I did that.  (And restarted the jail).  However, I still get the same error when trying to start apache.

I noticed a similar parameter  security.jail.param.allow.sysvipc  but cannot change this at run time and did not find anything useful about what this parameter is for using a search engine.

(As an aside, how would I change security.jail.sysvipc_allowed   and also security.jail.param.allow.sysvipc at boot time?  I added them both to /boot/loader.conf but they did not get changed at boot and I had to do the security.jail.sysvipc_allowed one again on the command line -- I have some vfs type kernel state variables set there and they stick)

I would appreciate some help with getting things set up so that I can run apache with mod_fcgid under my Jails on FBSD 9.


More information about the freebsd-questions mailing list