ntpd problems after port updates

Dean E. Weimer dweimer at dweimer.net
Wed Apr 25 17:52:10 UTC 2012

On 23.04.2012 14:52, Dean E. Weimer wrote:
> On 23.04.2012 14:10, Chuck Swiger wrote:
>> On Apr 23, 2012, at 12:08 PM, Dean E. Weimer wrote:
>>> Tried rebuilding without the with SSL option set, oddly it started 
>>> once after that, but a restart caused same behavior.  gdb doesn't 
>>> give me anything that I know how to interpret, gdb -c /ntpd.core.  (I 
>>> haven't really used gdb before, so if I am not doing something 
>>> correctly with it, please feel free to let me know)
>> Ah, you need to build ntpd with -g in CFLAGS & LDFLAGS for debugging
>> symbols to be present....
> at the risk of sounding like an complete n00b, how do I do that?
> After reading through the make man page, I decided on trying to build
> the port with "make CFLAGS+=-g LDFLAGS+=-g install clean" however I
> still get the no debugging symbols found message.  Does the
> information in in the Makefile for the port overwrite this option 
> from
> the command line?  Or am I just using the incorrect syntax here?
> (gdb) file /usr/local/bin/ntpd
> Reading symbols from /usr/local/bin/ntpd...(no debugging symbols
> found)...done.

Even more odd, I decided to go ahead and try a couple more systems, as 
this was working fine on my test system and one production system before 
I got to the one that broke.  I now have it running on 4 production 
systems and 1 test system.  The problem is on 2 production systems one 
with the openssl option one without, both these systems are running on 
identical hardware (Dell PowerEdge R310 purchased on same order).  The 
other two production systems are both totally different hardware wise, 
one is virtual on an ESX4 server, the other is on a custom built 
machine.  The first of which had the problem I did a fresh make 
buildworld and install last night as well as a rebuild of all ports.  
Problem still persists.  I am not sure what it is about these servers 
that's causing the problem, all other applications are running fine the 
configurations on these systems are all very similar, almost all the 
same ports installed.  One of the systems has a few more ports installed 
as its has more web based applications, but the virtual production 
server has the same ports installed, built with the same /etc/make.conf 
and /etc/src.conf options against the same /var/db/ports/ directory so 
they ports were installed with the same settings, only difference is the 
run time configuration, however the ntpd configuration is the same on 
all systems.

I have also discovered since the last email that the -d option isn't 
necessary to keep it running, the -n option which keeps it from 
detaching from the session will work as well.  I worked around the issue 
for now by manually running it with daemon and adding the -n so its 
detached and running.

  Dean E. Weimer

More information about the freebsd-questions mailing list