Installing FreeBSD 9 on an AMD 64 with 16 GB of memory

Jukka A. Ukkonen jau at
Sun Sep 25 09:41:47 UTC 2011

Greetings all,

I grabbed the FreeBSD-9.0 beta 2 AMD 64 DVD1 intending to use it for
installing FreeBSD 9 on a system with 2 AMD 4162 EE CPUs and 16 GB
of physical memory.
Booting proceeded as expected to the point when CD loader 1.2 was found
and the little rotor started running in the beginning of the line.
>From that moment on there was absolutely no progress.

So, I tried also with the AMD64 install CD and with the i386 install
CD, but the results were no better.
Initially I had the LSI SAS RAID controller providing a 278 GB HW
mirrored storage volume.
Guessing that the HW mirror might be for some reason confusing the
loader I deleted the HW mirror setup showing the actual Seagate SAS
disks to the system.
Still there was no progress after the CD loader started.

After getting a bit frustrated I tried Ubuntu 11.04 boot CD and
there was no problem at all booting the system. Ubuntu brought
the whole system including X11 up with no sign of difficulty.
Only then it started to dawn to me - the CD loader must be somehow
getting out of its mind when there is 16 GB of memory.

Are there any known problems with the CD loader 1.2 and
large physical memories?
Are there any known ways to work around this annoyance?

A summary of the HW environment:
2*AMD 4162 EE @ 1,7 GHz with 6 cores each
2*279GB SAS disk storage
LSI HW RAID controller

Any hints and pointers about what to try next would be welcome.

		// jau
.---  ..-  -.-  -.-  .-    .-  .-.-.-    ..-  -.-  -.-  ---  -.  .  -.
  /    Jukka A. Ukkonen,                             Oxit Ltd, Finland
 /__   M.Sc. (sw-eng & cs)                    (Phone) +358-500-606-671
   /   Internet: Jukka.Ukkonen(a)Oxit.Fi
  /    Internet: jau(a)
        .---  .-  ..-  ...-.-  ..  -.-  ..  .-.-.-  ..-.  ..
+ + + + My opinions are mine and mine alone, not my employers. + + + +

More information about the freebsd-questions mailing list