Help needed: sound/audio only semi-working

Ronald F. Guilmette rfg at
Sat Oct 22 01:45:48 UTC 2011

I've been bringing up a new amd64 box with 8.2-RELEASE.  So far I've managed
to get everything installed OK, including a boatload of freshly-built ports.
I've even gotten flash10 working with firefox... well...

Unfortunately, this is only MOSTLY working.  The video works great, but for
audio all I get is absolute silence.

The really strange thing is that after I followed all the directions here:

This command:

    cat /dev/random > /dev/dsp

*does* produce quite a bit of white noise sound.  However when I perform
the other officially recommended basic audio functionality test:

    cdcontrol -f /dev/acd0 play 1

with one of my favorite old audo CDs in the drive (AND with that special
little wire running from the back of the drive to my motherboard) all that
happens is that the CD/DVD drive apparently _does_ start to read some stuff...
as evidenced by the blinking access light in the front of the drive... but I
still get no sound out, and YouTube videos still aren't giving me any audio
even though the video seems to be playing perfectly.

So, um, I am grasping for ideas here on how I can debug this problem furher.
I really have no idea what to do next to get this debugged.  I supposed that
if nobody gives me a good suggestion, I'm gonna try swapping out that special
little wire for another one and then try swapping the CD/DVD drive for another
one if that still doesn't solve it.

Sigh.  :-(  I just checked and yes, the CD/DVD drive _can_ mount a data CD
alright.  No problems doing that.

So how can it be that this works just fine:

   cat /dev/random > /dev/dsp

even while this:

  cdcontrol -f /dev/acd0 play 1

causes the disk to spin up and read, but otherwise produces utter silence?

I'm flummoxed.

Any help would be appreciated.


P.S.  My motherboard (w/ onboard audio) is a Gigabyte GA-M55Plus-S3G.  Here
is what a get when I cat /dev/sndstat:

FreeBSD Audio Driver (newpcm: 64bit 2009061500/amd64)
Installed devices:
pcm0: <HDA Realtek ALC883 PCM #0 Analog> (play/rec) default
pcm1: <HDA Realtek ALC883 PCM #1 Analog> (play/rec)
pcm2: <HDA Realtek ALC883 PCM #2 Digital> (play/rec)

Additional info:

% sysctl hw.snd.default_unit
hw.snd.default_unit: 0

More information about the freebsd-questions mailing list