where to ask about problems with bsdinstall in 9.0RC2?

Frank Shute frank at shute.org.uk
Tue Nov 22 18:36:20 UTC 2011

On Tue, Nov 22, 2011 at 11:40:45AM -0500, William Bulley wrote:
> According to Ian Smith <smithi at nimnet.asn.au> on Sat, 11/19/11 at 13:29:
> > 
> > Unfortunately that concentrates on creating a GPT layout, encouraging a 
> > Linux-like single (plus a boot) partition - forget using dump/restore -
> > and says nothing much about installing over an existing setup with MBR 
> > partitioning and multiple slices, a not uncommon setup on many existing 
> > laptops .. eg here I want to install over a previous 7.2-RELEASE 60GB 
> > slice partitioned as I want it - 1GB /, 4GB /var, 16GB /usr and ~37GB 
> > /home.  Further, I want to preserve /home as is, despite having backups.
> > 
> > sysinstall's partitioning is more sophisticated; you get to specifically 
> > toggle on or off newfs'ing each partition, as well as specifying newfs 
> > options if you want.  So it's clear whether you'll be newfs'ing / and 
> > which other partitions, and which you'll be leaving alone, eg /home.
> > 
> > On BETA1 I recorded "Extract Error while extracting base.txz: can't set 
> > user=0/group=0 for /var/empty Can't update time for /var/empty .." which 
> > someone/s else also reported, which turned out to be misleading .. the 
> > basic problem is that the filesystem isn't empty, ie as after newfs.
> I hate to be a pest about this, but bsdinstall just isn't working for me.
> I grabbed the 9.0RC2 bootonly ISO for i386 and tried again to load this
> onto this Dell laptop.  This time the *.txz files had to be gotten over
> the network which took longer that with the DVD1 ISO.   :-(
> The files were fetched, and checked/verified, then the actual installation
> (extraction) began.  Unfortunately, I got the same error pop-up message.
> This time I have the exact text of that error message:
>    "Error while extracting base.txz: Can't
>     set user=0/group=0 for var/emptyCan't
>     update time for var/empty"
> Note the missing space or CR before the second "Can't"
> What confused me at first was the missing slash ("/") character before the
> two "var" pathnames.  But I now understand that is because I am updating
> (not installing) from a previously working (was 8.2-STABLE in this case)
> system where the four partitions (root, swap, /var, and /usr) are present
> and full of FreeBSD files, etc.
> If this is a "feature" of bsdinstall, then it should be mentioned in the
> documentation somewhere.  I used the "Manual" configuration method where
> I was asked to name the mount points for root, /var and /usr.  My question
> is this: "if bsdinstall can't handle installing over top of an already
> existing system on disk, then why ask the user for mount points on those
> already existing partitions?"  This seems weird to me.
> So now I am back to square one.  I want to load 9.0RC2 onto this laptop
> for reasons that aren't relevant to this thread, yet I am unable to do
> so because as of 9.0 sysinstall has been replaced by bsdinstall.  
> For the record, how do I upgrade to 9.0RC2 (or any 9.0 variant) from a
> system already running 8.2-STABLE?  Had this attempt been using the
> sysinstall method, I would have long since been up and running FreeBSD
> 9.x on this laptop.  Please advise.  Thanks in advance.

Can't help you with your bsdinstall woes but to upgrade from
8.2-STABLE to 9.0-RELEASE(currently RC2) branch you want to do a
csup(1)/buildworld cycle.


You should use the tag:

*default release=cvs tag=RELENG_9_0

in your supfile. More details at:





 Contact info: http://www.shute.org.uk/misc/contact.html

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20111122/628364bb/attachment.pgp

More information about the freebsd-questions mailing list